"Depth first" carving optimization

Just gong to hop in here and say thank you so much for this feature! It has been saving me so much time already!

1 Like

With respect to this optimization, does it extend to text? As in, is correct behaviour using Easel’s native text generator to carve each letter to full depth before proceeding to the next?

@danbrown, sorry, this optimization does not do that. For text, entire text object/word/sentence is done layer by layer.

Ah, thank you for the clarification!

1 Like

@DanBrown, everyone,
Please have a look at "Depth-first" carving for text and smarter "outline" grouping
We’ve done some improvements in “Depth first” carving.

I don’t know if this is how it supposed to work, but I cut out THIS last night and it seemed to be the most inefficient tool path ever. It would cut every shape to on depth and then cut every shape to the next depth. So instead of finishing one pocket to its final depth and then moving to the next, it would cut everything down to one depth and then repeat the process.

Seemed to take way longer than necessary due to the machine having to raise the bit to the safety height multiple times.

Any advise on this @Ruwan?

@Rusty, I had a look at it and I see those unnecessory rapids. This is one of the items we look forward to fix in the future.

Thanks for looking into this! I’ll be anxiously awaiting this fix!

1 Like

Was easel changed back? I have been creating a lot of g codes lately and until last night it was doing “depth first” last night I created 3 more and the program was ran the old way.

Any Ideas?
If it was changed is there anyway there could be an option to see (build version? updates?) in the menu. With Easel being an online program I am not in control of when it updates or changes. It would be nice at least to know when it does and what the changes are. It still is working fine however. If if there wasn’t an update is there any ideas why the code would change like that?

1 Like

Any chance you can share the project file so we can take a look and see why it might be doing this?

Any overlapping objects will goo back to the all together way.

All my jobs were running fine up until this update :frowning: Now all the shapes are cut layer by layer? What am I doing wrong?

I noticed the same thing! I lost a sheet of carbon fiber before I noticed this :frowning:

This was also a problem for me today almost doubled my carve time.

@MiguelAngelCottoMora, @TravisLucia could you share your projects please?

1 Like

Hi Thanks for the help :slight_smile: here the link to the file http://easel.inventables.com/projects/VU2OL08hyXJWNm7UE5UOOg

I’m having the same problem. It seems like if there’s a profile around a part, it cuts everything inside that profile in layers along with the profile.

Here’s my file: http://easel.inventables.com/projects/0a6nd5V9SVaWfI3xCLqp-g

I’m also having this issue. The tool paths are cutting each object layer by layer which is really slow.

@Mike, @MiguelAngelCottoMora, @Alex1380 We are currently working on a toolpath optimisation and will let you know as soon as it is available. I promise it will be faster than how it is/was now/earlier.

Hi @MiguelAngelCottoMora, @TravisLucia, @Mike, @Alex1380,

Latest changes are online now. Please have a look at "Depth first" carving for nested shapes

During this optimisation we had to re-implement part of our layering approach and for a while nested outlines were done layer-by-layer. We apologize for any inconvenience.

Thank you