Inventables Community Forum

Downgrade Arduino after firmware update issues


I can’t change the interface. Thus the only option/solution is to downgrade to the version that worked correctly for me. But that is still not working.

First see if you can talk to the Arduino with the Serial Monitor in the Arduino IDE.

Set the baud rate to 115200 and the “End of Line” to NEWLINE

Once you can talk to the Arduino again we can load in a back rev of grbl.

1 Like

@LarryM Just to make sure I started the serial monitor, and get the grbl interface.

I knew i had communication with it only the problem was compiling the grbl firmware. I downloaded three different version: 1.1f, 1.0C and grbl-x-carve.

For all i had imported them as a library (as stated in their “manual”). Only after clicking on the compile button i get the following error (also multiple warnings): Sketch uses 32266 bytes (100%) of program storage space. Maximum is 32256 bytes.

Global variables use 1507 bytes (73%) of dynamic memory, leaving 541 bytes for local variables. Maximum is 2048 bytes.
Sketch too big; see for tips on reducing it.
Error compiling for board Arduino/Genuino Uno.

Use Xloader to load in one of these versions and try your tests again

Okay uploading the hex file with xloader works. For all i can see i have the same interface again i was used to before getting the grbl 1.1f version. So thank you for helping me on this point.

Only I am stil curious why i cant compile it myself when the write it could be done. Afin, maybe a problem for later.

Thank you very much.

There are problems with the Arduino IDE.

There is a thread here on this forum that addresses the problem, but I don’t have the link right now.

I’ll look for it.