Dxf import partial display in preview

I searched and found several threads relating to dxf, but they all seemed to relate to size. I’m able to open the file at the right scale in Easel, but it does not appear correctly in the preview window. I have attached a picture of what I get, and it does not appear that it will cut correctly. I also tried converting it to svg format, which shows up fine, but doesn’t give me an option to select cutting the exterior of the shape, it just cuts the path. What am I doing wrong?

It is difficult to say from the image. Can you share the project?


Brandon R. Parker

If your SVG isn’t allowing to Edit the Cut Paths, then the shape is not a fully closed shape, but rather a series of lines…

There is a trick to close shapes that are nearly closed, simply add a shape using the shape tool (like a circle)
Then set the circle to 0 depth and move it away from your design,
Then select both the circle and your design and press crtl+J (aka the combine function) then the circle will disappear and your design will be a closed shape and you can edit the cut path.

this is a work around for non-closed design elements… the root cause has something to do with wherever you’re obtaining the SVG and them not being closed shapes… or possibly an option in the import step, i forget if this is a selection in Easel or not when importing??

Wow - thanks guys! I will try both when I’m at my computer later today. I’m not trying to be critical, but this has to be a fairly common issue with SVG files. I use Lightburn for my laser, and it treats those as lines and won’t let you “fill” until they are closed. Cura, that I use for 3D printing warns that a mesh isn’t watertight. Easel Pro is pretty expensive to just default to cutting through the workpiece and not give any indication why.

I really appreciate both of you helping with solutions. Thank you!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.