Easel Default to Inches?

Is there any way to have Easel to always default to inches instead of millimeters when I launch the program and after I make a cut? It is a bit annoying to repeatedly have to switch over to inches especially when having to jog the router quicker to your desired destination. Thank you.

Easel retains the setting from the previous job. If you close Easel in MM, it will open as MM next time. Closed in inches, will reopen in inches.

Best to always check unit of measure when starting a new project. You should only have to make this adjustment once.

No, this is not the case for me, maybe something is wrong with my software but it always is in millimeters. I want the software to always open in inches. Regardless of what project I’ve done last time.

@LanceWaligroski
You need to “save as default” under the Project menu. Set to the desired units first, then select this option. then the new project will default to that set units when first opened.

But also this saves additional Default Specs like the Bit and Material Type and Dimensions… and the current default settings can be found by clicking the Easel logo (or pressing Ctrl+o) then clicking the Options Tab at the top here.
And you’ll notice my units here says “in” if I change the toggle switch to mm and re-save as default, that will change this to show mm and new projects will open in mm units.

Thank you very much! I will try this right away.

Hello again,

I do not see any of these options that you mentioned and took screenshots of.


@SethCNC Your working in the Free Version of Easel, these options are not in Easel Pro.

@LanceWaligroski I would edit your image posted as it exposes your gmail address… don’t want to end up with more spam :slight_smile:

I promise, Easel should be retaining the in/mm settings upon closing your current project. What browser are you using? I use chrome and to verify I did the following…

Opened new project, changed in to mm and closed the project, then the browser. Opened new browser then new project and units was defaulted to mm now. Closed the browser, restarted the machine, opened browser then new project and it was defaulted to mm still. Computer are so fussy and I am not saying your wrong, I am simply telling you my experience and the results are exactly as I expected.

Now I am going to have to walk back on my comment, as I just returned to my computer and open a new project and my units of measure reverted back to inches. So now I am as perplexed as you. :frowning:

Yes, I’m even more stumped. I’ve tried to another computer and two different browsers, and I am not seeing these options anywhere, very frustrating. I may have to reach out to the Support team or something.

I have multiple accounts, one Pro… and a Free account . Both of my accounts Have this Feature.

EDIT: (or rather UPDATE)
Oh, I found the reason I have this feature and yall don’t.
This is an OPT-In Feature.
You need to go to this page and sign up for it…

1 Like

Hello @LanceWaligroski,
This feature is currently in early access testing. You can sign up by following instructions at Early Testing for Custom Project Defaults

Once enabled, the feature is available to both Easel Free and Easel Pro users.

1 Like