Inventables Community Forum

Easel Driver 0.3.17 released

Hi,

We have released a new version of the Easel Driver, v0.3.17. Driver is available immediately to be downloaded for Windows, macOS and Ubuntu Linux at https://easel.inventables.com/downloads. You will be prompted to upgrade next time you carve.

Release notes:

  • Fixed issue where custom safety height when retracting the spindle was being ignored.
1 Like

Hi is there an issue with this new version?.I’ve downloaded this and now the easel software wont connect my cnc.it just says plug USB in and turn machine on.before this it would carve designs but would only get to 37% then carves a random line,moves to one side and starts carving the image again.when i stop the machine it doesnt go back to original home position.i never had an issue before this update.I’ve tried going to an old update but thats not working either

Hi Stephen.
Can you provide more details to your errors? What computer (OS) are you using and can you report an error through Easel if the carving fails with a random line again?

Thanks!

Sounds like either:

  • stepper driver overheating causing a temporarily shutdown on that axis
  • stepper stalling due to mechanical friction or inproper rapid/acceleration values
  • or something is slipping, mechanically

Share your project so we can check the gcode, if its in the code we´ll be able to see it.

Hi thank you for your reply.i have reported the error as it happens.it wont let me connect now.the carve button is staying blue.this issue was happening random yesterday but let me connect a few times which is when the issue was happening.it would carve perfect then get to 37% an place a random line like it was jammed then move across the acrylic and start the image again.im using windows 10 laptop which I’ve used for the past 12 months perfectly fine this only started yesterday.i dont use gcodes i just send a jpeg image.they are the same images I’ve used for the past 12 months and they’ve always been fine

hi thankyou for your reply.im using a laptop in windows 10.the carve button is staying blue now so wont let me connect at all.when i press carve it says plug USB in and turn machine on there is power going to the machine and the USB is fine.I’ve reported tho issue a few times yesterday

This picture shows the unicorn i was carving then the random line it placed then moved above and started carving the design againn

Looks like your Y-axis is either stalled out or prone to overheat the stepper driver.

Which controller do you have?
Grblshield (top) or XController (bottom):

grblshieldxcontroller

This is the machine i use hun


Its just a desktop CNC router

Gotcha, DRV8825 stepper drivers.
What current limit are they restricted to?

The “flaw” of such controllers is that the two Y-steppers share a single driver, so each Y-stepper get half the power.
Also, the DRV8825 is not capable to provide enough current to utilize the torque potentional of the typical Nema23 steppers (Nema17 are weak to begin with)

So I think your troubles come from either:

  • Overheating Y-driver which cause Y-axis motion dropout, due to current limit is set too high / cooling insufficient
  • Lack of torque, causing steppers to simply stall out.

If the steppers stall out you’ll hear a grinding noise when it goes off path.
If the driver overheat you’ll hear nothing.

I think your right about the overheating and there isn’t noise coming from it.i feel daft now though,the computer picked a virus up,not quiet sure where from as i only downlaloaded the easel update :see_no_evil:.that’s sorted and the overheating sorted problem now fixed :blush:,thank you so much for all your advice

Ever since new driver was installed, my new xcarve doesn not carve to proper height. Now it is so bad i can’t even make a test cut. Whenever i try to carve the router bit goes about 5mm deep into the mdf and i have to immediately stop the carve and turn off the router. Everything was great before the driver update.

Windows 10, xcarve purchased 3 months ago. Dewalt 611 router collet and bit were not loose.

Have no idea what the problem is and can’t use the xcarve now…

Tried re-doing the machine configuration wizard, double checked and set material depth carefully. All settings seem to be right, but whenever a carve is started … the depth is way deep. It would probably break the 1/8th inch straight bit if i let the carve keep going.

Is it possible to install the old driver?

Can you provide us with the first 20 lines or so of the gcode?
Something its telling your machine to go 5mm down, or else its something mechanical happening.