Easel Driver 0.4.0 released


We have released a new version of the Easel Driver, v0.4.0. Driver is available immediately to be downloaded for Windows, macOS and Ubuntu Linux at https://easel.inventables.com/downloads . You will be prompted to upgrade next time you carve.

Release notes:

  • Security certificate updates for 2023
  • Upgraded connection libraries and driver framework technology
1 Like

I installed Easel 4 driver and now I can’t access Easel.


Yes Inventables has some fixing to do


Hello @Jay2703,
We did experience a short, lasting around~12min, outage yesterday. It was unrelated to the driver.
If you can’t use the new driver please get in touch with our Customer Success team at 312-775-7009, and they will help you get carving.

i cant install the upgrade
Screenshot (10)

I am having the same problem… I cannot get to a technician at the Customer Success Team. I am down and have a lot of Valentine Orders I need to be working on. :frowning:

I worked all this morning with (.3) no problems. I installed .4 and lost the capability to Carve correctly. After opening “Carve,” I was able go through all of the steps, but when I came to: Turn on spindle (ok), there is no longer the ability to raise the spindle. Thinking I might not have to do this step with the new driver, I selected “Carve” and spindle it immediately drilled down greater than my selected depth.

I was having this same issue. After installing the latest driver, easel wouldn’t for the life of me connect to my X-carve. If you haven’t found a fix for this yet, here is what I did. After hrs of troubleshooting and reinstalling and restarting etc…I finally tried reinstalling the previous driver that is found under the legacy easel drivers and it did the trick. In Easel, click the machine tab and then Drivers and Post-processors. And beneath the green download buttons you’ll see the Legacy Easel Drivers link. Just download your version and reinstall! Worked for me! Hope this helps at least until they fix the latest driver. Good luck!

1 Like

Any reason that I cannot find any information to actually inform the user base that these drivers only work for specific versions of windows and are not backwards compatible past I think Windows 8 or 7??

That key bit of information MIGHT be handy to include on the DL page.

Hi @SethCNC,
As much as we would like to, we can’t support such old versions of Windows. Even Microsoft has stoppped supporting these legacy systems. If the driver works on Windows older than version 10, that’s outside of our control and cannot be guaranteed. Version 0.3.21 of the driver will stop working for a lot of folks February 11, 2023 due to security certificates expiring.

Please see

1 Like

I can no longer use EASEL.
Every time I press the CARVE button it asks me to update the driver, but I made this update a week ago and every time it asks me to update.
The program is unusable

Hi all! In regards to the latest Easel Driver update (0.4.0), please note that the previous version of the Easel Driver will expire tomorrow, 02/11. To ensure proper functionality with Easel, all users should update to the newest Easel Driver, which can be found here: Easel - Downloads

If you have any trouble downloading or installing the new driver, or connecting to your machine, we would recommend checking your operating system. Supported operating systems are limited to the following:

  • Windows 10 or higher
  • MacOS 10.12 (Sierra) or higher
  • Linux Ubuntu 22.04

As much as we would like to, we can’t support outdated versions of these systems. For security and safety reasons, all users should ensure that their operating system meets the requirements listed above.

If you are still having trouble after confirming that your operating system is up to date and reviewing the Easel System Requirements, please visit our Support Center for instructions to resolve Connection Issues. If you need additional support, please reach out to our Customer Success team during our regular business hours Monday-Friday 9 a.m. to 5 p.m. CT and Sunday 12 p.m. to 4 p.m. CT.

Thank you!

Why would you push a new version without testing or even have support available to assist in case of an issue. I was supposed to deliver a job today Saturday and now I have an angry customer because of an error you guys did. This is so Unacceptable !!!

The installation gets stuck at verifying installation and does nothing.


@SewardSuarez @MarcelloCaroli
I’m probably going to catch some hell for this from the brand… but it must be said, there’s too many people with a bricked CNC as a result of this “update”

I suggest using a dedicated gcode sender. I prefer OpenBuilds Control, but there are a handful of other options out there to control your grbl based cnc (including the X-Carve)… UGS, Gsender, PicSender, Candle to name a few of the other options… The ONLY thing you’d need to setup in openbuilds is the probe and I discussed that setup in my Livestream yesterday (check my channel for that Live, but here’s the general Openbuilds overview) Best CNC Software is OPENBUILDS CONTROL - Cool Features - YouTube Ohh and all of the gcode senders I listed above are all free.

1 Like

I’ve not really paid too much attention to this until now due to the increase in posts. I’m using windows 8 and ugs and so far so good, so backing up what Seth says. Although I can I don’t like running carves on easel due to how the spindle travels across the workpiece from home position to work zero, ugs is a far better/safer option if you don’t want wrecked clamps and end mills. I also remember seeing posts about the baud rate needing changed, is this part of the same issue or related to the x carve pro?

That Baud Rate change thing appears to only be for the X-Carve PRO and from what I’ve read so far, it stems from some of the earlier models that had a different controller box layout that’s more prone to EMI noise, so rather than address those specific units they pushed out a Non-Standard Baud rate change to All X-carve Pro machines, which IMO seems like a pretty silly solution, to say it in a PC fashion :person_shrugging:

this is one of the biggest problems with having a web-based app. People cannot lock their systems in time. My system was working perfectly, on a dedicated laptop that I didn’t update, and now it doesn’t work. the updates only serve to introduce more problems. And here I am, a half day wasted chasing a solution to a problem that didn’t previously exist for me. Give us a desktop version of Easel please.

I’m running windows 10 and Easel keeps crashing now after update i run rougher fine switch to finisher and screen goes black and crashes.

what is link to that or is there a phone number for Customer Success team

Scroll to the top of this page, select “Support” then scroll to the bottom of that page and you’ll get these buttons…