Easel Driver 0.4.0 released

Yes to everything asked there.
Ugs has the function of cell phone pendant, basically you scan a qr code. Your phone opens a website and so long as you’re on the same wifi network as the computer it’ll let the phone jog and such.

You still need the computer connected as its streaming the gcode file throughout the carve duration so it’ll have to be plugged in and with ugs open just like with easel sending it .

Is it me or did this change come out with the latest update. The “Attach” button now moves the router downward. This seems to be a function of the wrong button, and somewhat dangerous. The first time it happened to me I was startled and canceled the carve. It should have been after clicking the Attached! button.

Which post processor would be needed in this configuration?

I did that and it told me at version was no longer supported.

So I updated my windows 8 laptop and the driver installed fine (even though it’s not supposed to work) but on my windows 10 laptop it almost completes the install the freezes every time?

My windows 10 laptop still works with the older driver, so I’m a bit confused?!

I too wonder why the router would LOWER when the “Attach” button is pressed. Before, I usually had to raise my router almost an inch and a half after zeroing to connect my dust collector. I’m not sure I even understand the purpose of this new step.

I agree if it were to raise a adjustable amount when clicked, the lowered a adjustable amount or to step over amount when “Attached” button was pressed wound make sense.

1 Like

Is this issue resolved? or is there a workaround? My setup also gets stuck at ‘verifying installation’ and I’m running windows 10.

Here’s the latest update to the 0.4.0 Driver release

1 Like

@DavidLitz, @KeithLaurie,

Hi David, Keith

We deployed a fix for this bug where the z-axis would lower in certain cases when it was expected to raise to attach the dust shoe.


1 Like

Thank you

I’ve attempted to install Easel Driver 0.4.0, but little success. I find it ironic that there needs to be local software for a program Inventables insists is “perfect” as a web based program.

The tablet I have been using ONLY for CNCing for several years has Windows 10 Home installed:

I have downloaded and “installed” the Easellocal package (multiple times):

How can one know if the “Driver” is “working” or “installed properly”?

I still get no connection and this pop-up when clicking the blue carve button:

I got so pissed off last night that I went as far as deleting my machine in Easel and reinstalling… which get this, it would “connect” for setup and I could jog and stuff but then when opening a project to carve… blue buttons. :face_with_symbols_over_mouth:

I was so IRATE at this point of needing to get a simple carve done, that I have done hundreds of times, that I spent another hour getting UGS sender set up and finally carved what I needed. Unfortunately because I “wasted” 3 hrs on this SNAFU, I won’t be able to ship the finished project out today like I need to.

I get that old versions of Windows “aren’t supported”. I get that you’re company line has to be that we can’t support old versions. But guess what, your NEW version doesn’t work either all the time and your help files are all OLD and OUTDATED. (If you are “forced” to deprecate a version of the software then you better have CURRENT help that has old help deprecated too)

I purchased an X-carve years ago because you’ve touted that there is Easel and it is easy.
(Yes, there is other software options, I shouldn’t have to use others if I don’t want to)

What is the “solution” to get Easel functioning again so that my business can get back to its preferred workflow:

Any updates on this issue, @KacperMarcisz ?

The Issue you reported above?

You may need to clear cookies and cache and retry or another option would be to try a different browser. The issue is within your PC’s settings as I’ve successfully performed the install on multiple PC’s without seeing the reported issue.

Hi @LarsvR,
We have tested this driver on multiple computers running Windows 10 & Windows 11.

You can check Event Viewer and see if any errors are showing up. Our excellent Customer Success team can help, either by calling or filing out a ticket.

I would also recommend you look at upgrading to latest version of the OS. To my knowledge upgrade to Windows 11 is free, and Microsoft will stop Windows 10 support in just over 2 years.

1 Like

There’s a lot of info here, I have three kids under three and havent used my xcarve in a bit, but promised the wife I wold make a gift.

My shop PC is windows 7 pro.

Easel tells me i need to update my driver, it installs a driver and bricks itself? There’s no validation that the driver works on the PC, it just installs a wrong driver?

What’s the recourse here, I need to tackle this project. Do I revert back to an older driver? I tried that and it says it needs a new driver, but I know it doesn’t. This machine worked last time I used it, the software and driver worked fine.

Reading other threads it would seem that because easel is not a normal application but a web application, it can change at any time, it’s not like all other software I use.

Inventables changed easel software to no longer work for thousands of users, and did not offer any back compat or kind of legacy website/backend. Many people use older machines as their shop machines. Just another reason I wish I purchased something more professional.

You can tack ‘pro’ onto your software, but this is anything but professional.

**Note that I am not Inventables Staff, this is a personal opinion of a Easel user.

To Export the Gcode and use a different program as the Gcode sender that works with legacy Windows 7.

Windows themselves implemented the security update requirements and made it such that in order to comply with Windows 11 that Windows 7 and 8 would no longer function with the driver. This is simply Inventables complying with Windows 11 requirements. And yeah if you read the Easel Terms of Service, this is something that the “thousands of users” agreed to when using Easel.

It should be noted that the Above Driver release date and the above mentioned effective date of Feb 11, 2023 was actually walked back on and updated to July 25, 2023 which allowed users more time to become aware of the change and to update to Windows 10 or 11 as noted here:

1 Like

Hi @ChrisEvans,
I am one of the developers at Inventables. I wanted to answer couple of your questions.

First of all I apologize you can’t use Easel with your existing workflow. It is very annoying something that used to work just a while ago doesn’t anymore. I know it sucks.

As software company we do have to comply with security regulations, industry best practices and tooling support. Windows 7 has lost the manufacturer support over 3 years ago. Here at Inventables we tried to keep support for as long as possible, and we gave users generous amount of time to update, even though systems older then Windows 10 were not officially supported for a long time.

I also want to clear up the “thousand of users” statement, it’s not accurate. It’s unfortunate @ChrisEvans you were in the group of people affected. We did internal analysis to make the impact as small as possible. At some point older legacy systems do have to be deprecated though.

As a path forward I would recommend checking if your machine can be upgraded to Windows 10. It is a free upgrade if you hardware supports it. It will put you on much safer platform, one that is supported by Microsoft.

I am going to close this thread seeing how there isn’t much new discussion. If anyone has issues with the driver please check the system requirements, contact our Customer Success team, or start a new thread on the forum.


1 Like