Inventables Community Forum

Easel driver missing?

Today when I wanted to carve something I got a message from Easel to install the driver… That’s weird as yesterday everything worked fine. So I (re-)installed the driver, but still get the same message (I did restart Chrome). What’s happening?

I think it is happening to everyone. I am having the same problem.

Guess that’s no carving then tonight :pensive:

Sunday night Easel prompted me to download the NEW driver (3.2?)… the notice stated that I did not HAVE to run the new driver, but also warned that the old driver may stop working without notice (something to that effect)…
I have not run a carve since Sunday, so I am not sure if I have the same problem… I guess I know what I will be checking after work.

Same problem here in the Netherlands… Too bad…very sad :pensive:

I ran a carve AFTER installing the new driver. the carve ran with no problems… now I’m itchy to get home and check the system…

Hi Heiko, do you have found a solution about this trouble ? I have the same problem.

Yep, happened to me too. I ran one job, then it prompted me to update and I (not thinking) said OK, and now easel can’t find the driver. I ended up exporting the gcode and running it in chilipeppr to get through the rest of the night’s work.

I ran easel no problem after it prompted me to update but not run the program for 1 project. Now I have stuff I need to get done for projects and easel will open but it will not connect. I have uninstalled and reinstalled, attempted to install older versions with no luck. Now I am attempting to install the new update again and my computer is stuck on “Verifying install”.

@PhilJohnson - don’t know how to export Gcode and send in USG. You have a video for that?

@Zach_Kaplan @EricDobroveanu any insight into the Easel driver issue?

If you go through the Easel machine setup and have Easel set for automatic spindle control, it adds M3 and M5 automatically when you export. If you use M7/M8 and check the box for it in Easel, it also adds those commands as well. I used to modify my GCode exports and verify everything but just last night all I did was download and send with UGCS and both spindle and my shop vac turned on and off as expected. Just letting you know that Easel can add those automatically if it’s configured for that.

Sorry to all, but any news from inventable about tous trouble ? I have no contact between gshield and easel after the new driver … do you have solution to already use easel for each step. Many thank to all of you

I contacted Inventables support, they’re having their devs look into the problem…

Thanks Heiko, can you keep me inform if you have any news ? Thanks :wink:

Strange I updated my driver and had no issues.
Ran a job for 3.5 hours

running a job as i type… no problems with the new driver here…:triumph:

@Heiko, @Inkedmedic, @S_Kuiper, and anyone else who’s having Easel tell you that you need to install the Easel Driver after you’ve already done that—can you send me the Easel Driver’s error log file? (As a private message is fine.)

Mac users: /Library/Easel/iris.error.log (that’s Library in the root of your hard drive, not the one in your user folder)
Windows users: C:\EaselLocal\iris.error.log

@RelabManager, if it’s saying it can’t find your machine, that would be a different problem. Sometimes restarting or plugging into a different USB port can help, but if the problem persists, email help@inventables.com.

/Library/Easel/iris.error.log had a modified timestamp of dec 2016 so I renamed it and reinstalled the driver. Now I have a zero length iris.error.log and still get prompted to install the driver.

Thanks for the info I also have the same problem.

Don’t think there’s anything useful in the log as it’s also timestamped 2 days ago (when things still worked):
DEPRECATION: Please use require(‘serialport’)instead ofrequire(‘serialport’).SerialPortDEPRECATION: Please userequire(‘serialport’)instead ofrequire(‘serialport’).SerialPort`
undefined:0

TypeError: There’s no write queue for that file descriptor (after write)!
at TypeError (native)
DEPRECATION: Please use require('serialport') instead of `require(‘serialport’).SerialPort``