Easel G-Code HELP!

So, I am trying to do a halftone picture and I tried using a program called halftonev1.5 and sent the gcode into easel. But, what I get is an error message that looks like this.

The G-Code file is here: Test halftone Pic.txt (902.0 KB)


Just a wild guess.

This G-code file contains line numbering, which is an optional feature in G-code.

You could try turning off line numbering in the program that generates the G-code, if that program has the option to turn it off, to see if that is the problem.

Alternative, you could edit the G-code file to remove the line numbering for a few lines and see if the error doesn’t occur until the first line containing line numbering is up to be sent.

The N100, N110, etc. is the line numbering.

UGCS sends this file without error.

Here is one I just generated…Prism Carve 1.nc (58.1 KB)

I tried it without the line numbering and I can’t seem to get it to work.

Sorry, I am kind of new to this. I don’t really understand what you mean by a perl program. Can someone tell me how a perl program works, or how to do it?


Is the failure mode the same? How is it failing now?