Easel isn't seeing my x-controller please help (solved)

my specs:
motion controler: x-controller
rail size:1000mm x1000mm
lead screw:acme
spindle:dewalt 611

OS: Windows 10
browser: google chrome (and Explorer)

My problem: in machine setup, after entering “machine details” and clicking “confirm settings”, easel stays on “connecting to x-carve…” indefinately. (never connects to bring me to “Test your wiring” screen.)

what I’ve tried:
-pluging in then turning on
-canceling and trying again
-updating all recommended drivers, restarting and retrying
-checking connections of all internal wiring (ribbons, internal USB cable, e-stop cable…) and trying again
-trying again in explorer instead of Chrome

I’m not all that software savy, so i’m lost now. Please Help!!!

Recommended drivers including the FTDI USB drivers? That’s the important one for the Xcontroller.

sorry, I’m not sure what updating it ‘local’ means. I was using the same network and wifi connection when I updated.

I got the FTDI Driver (CDM21224_Setup), I also got the Arduino 1.8.1, and EaselDriver_0.3.3

I did notice however, that even though everything is connected properly inside the x-controller, the power light doesn’t come on when I flip the power on. The fan spins, and the power supply makes noise as though it’s running, but LED ‘power’ light doesn’t light up.

1 Like

Just read another thread recently where the problem might have been the E stop. Make sure it is not engaged. Good luck.

and check the connectors are seated all the way; not just the locking catch. Push all the way in.

sorry, where would I find earlier versions of Easel? I think I’m confused.

e-stop moves freely, not stuck in engaged position

all internal and external connectors seated evenly and completely in, even the external ones connecting the limit switches, the z-probe, and the x,y1,y2, and z axis.

Give them all a physical push in.

I think I already did that, but I’ll give them another try in the morning.

thank you JDM, MichaelColey, PhilJohnson, and JustinBusby for the help so far.

Twist and pull the e-stop upward.

Yea the Estop shouldn’t have any play at all in it. If there’s play, then it pushed down which is keeping power from the board. The fan gets its power separately and runs even with the Estop engaged.

1 Like

Thanks Phil, I’ll try local 3.2

well, all my connections were sound, the estop was not engaged, easel local 3.2 didn’t fix the problem, easel still doesn’t see the x-controller, and I still have no explanation for the power light not lighting up. starting to think I got a bad board in my kit. there are no obvious indication of damage, but I’m out of ideas. I’ll call the customer service in the morning tomorrow and see if they can work some magic.

problem solved, the FTDI Drivers wouldn’t install at first. Inventables’ Customer service is Excellent!!!

1 Like

Sorry to open a closed thread, but I literally have the exact issues as the OP. I have installed the FTDI drivers, restarted my computer several times, checked the E-Stop button, checked all connections, etc.

The fan comes on, but no power light and the setup won’t connect. Any other suggestions?

Thanks for the replies.

I twisted and pulled the button and still no luck. The button seems to be fully retracted.

I am a bit of a novice with this stuff. Would you be able to tell me or direct me to a page that can tell me how to bypass the panel? I don’t want to inadvertently break anything before my first use of the CNC.