Easel not responding in Safari

New build, Mac pro os 10.9.5, Safari, let me go through entire setup, everythings fine. Continue on to Carve and easel does nothing but act as if it were about to load. Tried in firefox and also no response. Any ideas? My crappy computer?

Yeah I jumped the gun on the post, rookie move. Installed chrome right afterwards and worked. Definitely need to upgrade asap your right, work with what I got till the funds are right. Thanks for the quick reply, I really apreciate it.

I’ll look into that, thanks again.

Hi MakeShip,

We list 10.10 or higher in our system requirements for Easel. As long as you’re on 10.10 or higher, Easel should work equally well in any of the latest versions of the major browsers (Firefox, Safari, Chrome, Edge, IE). If anyone at Inventables recommended Chrome specifically, that was an error. We do not recommend one browser over another.


Ok. If there are ever any issues with one browser and not another we are interested in learning what they are and fixing it.

I have now made a few test runs with my current OS using Chrome with no issues so far. While I know I still need to be running the minimum requirements I’m also just trying to get by with what I have till I have a dedicated setup in the near future. So… Maybe it’s because of me not updating or maybe others have had problems with safari as well??