Easel not working on laptop - broken download?

Easel not working on laptop. Downloaded software when prompted. Extracted and rebooted pc
PC does not recognize S2
Tried all ports - fail
went to device manager - unrecognized device - update driver -pointed to easel folder - no drivers found

is there another download to get the proper drivers for windows 7?

by the looks of it, it seems easel no longer supports shapeoko? uninstalled and reinstalled everything and the only option i can download is x-carve .Use to love easel, but i’m not going to buy an x-carve to continue using easel

this sucks

try the xcarve one. your computer shouldnt know the difference as the machine is just some motors, rails and wheels

Hi @GamerGuy I am sorry you are having problems Easel supports Shapeoko 1 & 2. You don’t need to buy an X-Carve to use Easel. Whoever told you that is wrong. If they work at Inventables I’m going to fire them immediately. That is just not true and they would have lied to you. We don’t tolerate dishonesty at Inventables. Please message me privately to let me know who said that. We have a drop down in the machine menu that indicates Shapeoko 1&2.

Regarding the issue it looks like a couple of things may be causing the problem. Here are some things to look into.

  1. When you connect the USB does the Arduino connect?
  2. If not do you have the Arduino drivers installed on your PC?
  3. What version of GRBL are you running?
1 Like

@GamerGuy,
I just went through a similar setup to help another user and to me it sounds like the Arduino drivers are either not installed or you had the USB cable plugged in before installing the drivers. I had the same thing happen when I tried setup with the cable plugged in, Windows wanted to load a drive but could not find it so it called it an unknown device.

Unplug the cable, make sure you have the Arduino software installed http://www.arduino.cc/en/Main/Software

Software instructions are on page 15 of the X-Carve instructions http://x-carve-instructions.inventables.com/step15/

That should fix your issue

1 Like