Inventables Community Forum

Easel Pro is not longer tiling correctly

Hello,

I am using Easel with my saintsmart CNC router. I have used it to carve out a control panel for an arcade (manual tiling) and did some eatching work and loved it. So I paid for the Easel pro and it did everything correctly till I tried to recut my arcade control panel again. This time I opted to try the tiling option that Easel pro uses. First time is great, second tile it plunges the bit way too far and travels of the piece ruining it. I thought it may be a problem with easel and then exported to Gcode all 3 tiles seperately and again it cuts it correctly until the second tile. Ruining yet another piece of wood. I don’t know what to do. I am using automatic for cut depth and speed and everything.

Can you share the project or the gcode?
Are you using Easel to control the machine?

thanks for the reply. I am using easel pro for tiling and I had called support. They noticed an issue with easel and layering… my solution was to remove the bottom parts do the cut and then cut again with the deeper part… not perfect but what can you do.

Can you elaborate?

It seems that easle gets confused when trying to deal with multiple layers of a cut. In the attached pictures are two failed attempts I did which sucks. both carvings are 600mm long… my CNC is 300mm long.

the carving on the right is a 3 tile 8 inches each. It is on a .75 mdf board (calipers said .82) I set the depth in easle to .92. The one on the right I drilled the button holes after easle didn’t cut all the way through. The one of the left was my latest attempt. I tried to make the tiles so each did a part of the middle section. For some reason it treated both tiles differently and in the end the router stopped not completing the cut or going back to home position. .

any idea why it is doing this? Going to attempt a 4th cut but afraid it will not work again. I wonder why it will not cut all the way through

Can you share the project or resultant gcode?
How are you setting Z-zero between tiles?

My guess would be this is a mechanical issue.

Thanks for the reply. While I do concede that it might be a mechanical issue, Realize that did work before I moved from Easel to Easel Pro. One that that did happen though is inexplicitly the website lost all my setting to my machine. I had to reconfigure everything and for some reason it would not hold my dimensions correctly.

attached is a picture of the section messing up from Easel Pro & the Geode generated from it. control panel_mid control panel_mid.nc (176.7 KB)

Your machine settings are stored locally on your controller.
If you re-run machine setup the GRBL parameters will revert to default (based on the information provided during setup) hence the change in scale of dimensions.

Thanks for the reply. I am new to CNC routing and Easel so forgive this question, by controller do you mean like the laptop I have connected to my CNC? Because I guess I can see that if any cookie gets clean. As I have a saintsmart 4030 I have to go through the default again. It hasn’t been acting right since then though. Though if I set the dimension shouldn’t that be stored in cookie? I mean I can still connect to my machine just it resets to 250x250 when it should be 400x300

No. The controller is the what takes commands from your computer and controls the machine. Some sort of arduino based microcontroller.

no idea what the controller is. it is a saintsmart 4030 in the setup it had me select the aduino or whatever setting. I have since just used easel to output gcode and cut that part in two separate pages. No idea why I can’t do both at the same time.

Most likely the box your USB connect to.
PC/Mac → USB → Controller (which convert signal from PC into motion on the CNC)

Thanks. All I know is the control box my laptop is plugged into is based on Grbl V1.1 software. Either way I do not know what this got side tracked. For the issue of it not cutting through I raised my sacrificial board to a …5in vs …25 and it is cutting through it fine now. I still do not know why the easel application cause the order to be messed up when layering the objects. From the gcode I uploaded on the central part it plunges directly down to cut the middle section instead of carving from the top like it usually does. The crux of that problem is easel is creating gcode incorrectly and I don’t know why. I have a work around but not a solution.

Can you share the actual Easel project?
I didn’t understand what you meant, but I just looked at the gcode. I see now.

If I can take a look at the actual Easel project, it will be easier to tell if this is a settings issue or a bug.

File–>Share–>Share with Link–>Save
Paste the URL here.

well I did not want to share this publicly but I need to find out what is happening…

it is the last panel, middle panel …

Go ahead and unshare your project if you want. I was able to pretty easily replicate the issue.
The problem occurs when you have a pocket within a pocket and tiling is enabled. Easel will ignore stock and plunge to start carving the deeper pocket as if there was no stock to be removed before the bottom of the lower pocket. It occurs with profile cuts within a pocket as well.
Disable tiling and it works as it should.

@AlexRobs You might want to just tile the old fashioned way. Procedure is the same.
@Brandon_Cullum
@JeffTalbot

Okay, so it is a tiling bug they have fix as they don’t have the but in the system without it. Good to know and very unfortunate

Thanks for confirming the bug and showing me why it happens.

Hello everyone,

We are aware of this issue and will be working on a fix.

1 Like