Easel returning home early cut

First of all - I’m new to this - just built a WhittleCNC and trying to get it running. I’m doing a test cut in Easel, just an icon and some text. I’m able to home, get everything set up well, and hit carve - the machine will wait for a few seconds, then begin the cut. I’m usually getting just a fraction of the first letter of the text, then the spindle raises, and goes back home.

I’ve tried it a few different times, all with same results. I had the USB cable plugged into an extender and took that off. The cut only runs for 20 seconds or so, give or take before returning home. I’ve also noticed that the progress bar does not initiate until after the machine goes back home after the initial cut.

Any suggestions?


Sounds like part of the design is unable to be carved based on the tool selected. Check the image on the right hand side and check for red spots, that indicate areas that cannot be carved.

I did check for the red indicators and there were none. I also tried taking out the text and just carving an icon (stormtrooper if that helps) and got a similar result.


You can export the Gcode from Easel and then open it in a text editor to see what its doing.

ok - I read somewhere else where someone had luck using a USB port on the motherboard, rather than through a hub. Tried that today, and so far, things look good. The status bar came up immediately, and the cut is still going. Fingers crossed, but it appears to be a USB placement issue.