Easel seems to refuse to drill some holes

I am trying to make a simple tool holder and as part of that I need to cut a lot of small circular holes. For the 1/8 inch diameter tools I tried to cut holes .127 inch diameter. Easel will cut some but not all of the identical holes. Am I missing something?

I have removed everything except a few of the holes to show the issue. In the attached picture the middle holes are .127 diameter and .74 inch deep. 4 of the 6 small holes have a toolpath, but the 2 top left holes do not. Is this a problem with Easel or me?

Hi Allen,

Could you share the URL to your project? If you would rather do this in private, you can click the ? button on the right side of Easel to contact Inventables support.

Most likely the circles are not actually identical, and some of them are too small for your selected bit size to cut without going outside the lines. I’d have to look at your project to confirm.


Hey Jeff…we’re you able to address the problem?

Here is the URL for the test project


I have a bit size of .125 inches selected. All the small holes have a diameter of .127 inches. I could understand if it refused to cut any of the small holes, but it seems odd that some of them are ok and other are not. Any help would be appreciated.

I took a quick look at the project, and there does appear to be an issue with Easel. It may be some kind of rounding error. I was actually able to get 2 more of the circles to show cuts just by re-typing in .127" for each of their diameters. This worked on all but the top left small circle.

We will take a closer look at this today and get back to you.


Thanks Jeff, This is the first issue I have had with Easel. It has done a great job for me and every month it continues to improve. Without software like Easel the learning curve for the existing CAD/CAM software is crazy steep, So I really appreciate Easel and the work the software team has done!

In a typical situation, would there be any problems/errors trying to cut a .125" hole with a .125" bit…? Should holes and radii be slightly over sized when drawing the CAD…?

Hi Allen,

It does look like a rounding error issue. If you slightly increase the diameter of the circle to say .1275", then it will generate paths (note: it will round in the display to .128" but will be stored as .1275"). It has something to do with the way the exact position of the circle plus its radius gets mapped to a discrete space for the purposes of calculating intersections and overlaps, etc.

We are going to work on reducing these types of rounding issues in the future. We also may look into some type of “drill hole” support, so that you don’t have to draw a circle for this type of operation where you just want to plunge the bit down and back up.

We’re glad you’re enjoying Easel! Thanks for the kind words.


1 Like

Hi William,

Yes, it’s possible to come across rounding errors when doing that. The position of the shape and its size have to get converted to a discrete space. The boundaries might get rounded off slightly to do this. If they get rounded down then they might be too small for the bit to fit into.


Your solution worked, Thank you. All the holes are now in the toolpath.

One suggestions from this, when I select a group of objects, (circles in this case) it would be really nice if I could just change the Width and Height size for all the selected circles at once. This would be very helpful when I need to be sure all the items in a selected group have the same height or width.

Currently when a group of objects is selected and a change is made to Height or Width Easel appears to re-size all the objects so they fit in a a rectangle with the new dimensions. I have never had a need to re-size a group like that before but I can see where it might be useful, so maybe adding a way to change the group edit behavior would work,