Easel settings and limit switches

Hello everybody, I am new to CNC and having trouble with getting my limit switches and homing settings. I did have my limit switches working on easel test page but when I changed some settings they stopped working. My settings seem different as my hard limit is $16= instead of $21=. Why is this? Also now when I press the limit switches I get Alarm: limit switch MPos. I am really stuck. I have sent some snap shots
Thanks Russ


Hi Russ, your settings are assigned differently because you are running grbl version 0.8c (i see this in your 2nd photo under the Hard Limit Alarm line) and the current versions use by most users are 1.1F and above. There were major revisions on 0.9 and 1.0 and 1.1 that changed the setting assignments, this is why your limits are $16 and other peoples are $21.

IF your controller board is compatible with an updated version of Grbl (not all are) then I suggest updating by uploading new firmware via the Arduino console software. I was able to follow a 12year old’s instruction tutorial on YouTube when I first updated mine a few years ago… If you’re unsure if your controller is compatible with new grbl firmware then you might want to purchase a new controller, compatible grbl controllers run about $30 on amazon.

Hi Sethcnc, thankyou for your information, I down loaded the new version of grbl and my stettings all adjusted.
I have set up my CNC workbee with Arduino uno shield and all the jog and homing is spot on. I home my machine and then put my new project in to easel. I then run through all the parameters wood, thickness, bit, to the workpiece corner, touch corner with bit and raise spindle. New position selected. I press carve and my spindle goes on a mission to somewhere else and to the hard limit switches if I would let it. What am I doing wrong. My work bed is 750mm x axis and 1000mm Y and A axis. I set $130, 31, 32 to 500 as to reduce the work area for now. I feel I am so close to carving but don’t know what setting I am doing wrong. Thanks Russ



Hmm, the thing I’m a little unsure of is those calibration settings

Do the jogging increments work properly?
You tell it to jog X amount left/right and it jogs that actual distance (the more the easier it is to check accuracy)
Repeat for Y and Z axises.

Oh also, can you share the easel project just so I can take a look at the design and make sure there are not anomalies off in space causing it to go off to that area outside the work area on purpose.
In Easel go to Project>Share then select “unlisted” and copy that link, then paste it over here.
Thanks!
. . . OR you can just open a new project and just toss in a basic square or circle to ensure there is no other accidental design bits off in space and re-try the carve & see if it wants to crash again

I can jog my machine manually all axis, how do I tell the machine to jog auto without a project g code? I agree I think I have a grbl setting out of sink. I have tried two new projects, one project of the material clamps the machine moves from home and passes the new work position and starts the carving movement towards the back of the baseboard working area. I will send on the project.
Thanks

1 Like
1 Like

For calibrating a workbee style machine i reslly like the calibration wizards built into openbuilds control software… but its probably best to stay within easel for now as its a bit simpler process…
Heres how to calibrate your axis movements within easel: (i know he has an xcarve in this video, but the process is identical for every machine :+1: )

I found a few issues with the Clamp project, But none of them are related to the issue you’re reporting in this post. . BUT here’s how to fix them anyway :smiley:

And here’s the file I ended up with at the end of that video.

Thankyou for helping me and looking at my project. The video was very informative and I got my machine to find its work position. I set it all up to carve and when I put my spindle on, it interrupted my internet signal on my laptop. So I never got to carve. But I can watch the machine go through it’s g code without the spindle on. Is this a common problem?

1 Like

Um, you can carve without internet, so that really shouldn’t be an issue. Easel doesn’t need internet and if it cuts out, that wouldn’t cause the carve to stop.

However it sounds like your CNC tripped its own power supply off possibly, and this can happen with a defective spindle, or some issue with spindle wiring. OR you’ve got the Spindle VFD connected up to an outlet with GFCI protection and unfortunately VFD’s don’t like GCFI circuits. . .

I should probably mention that I have a workbee with that same VFD and a similar spindle :+1: