Easel update bricking machines [information?]

On another thread @KacperMarcisz was saying that the issue with Easel no longer working with Xcarve machines on older operating systems was out of their hands and it was a windows security issue that meant Easel no longer worked with X-Carve machines.

Can I get clarification there, I run multiple shop machines that all have drivers from my shop PC, none of that software or hardware has stopped working. My 3D printer which has a driver and even operates on gcode, it still works flawlessly. Photoshop still works with my scanner, my printer, etc… I even have other arduino devices that still work flawlessly with their drivers.

How did all those companies manage to pull this off? Is it because they offer multiple drivers? I see that almost all companies have you select an OS to get a driver, but Inventables does not? Does that mean inventables made the business decision to only support windows 10+ and the business decision to have their software not work back compat with an older, existing driver?

Still trying to wrap my head around this.

Perhaps it is because Inventables are trying to run a machine from a web browser, a “security risk”, instead of the software being its own executable file/window . We have to download a “driver” for the web based program to communicate with the hardware, why is it not its own program window?

Their driver doesn’t work for “every” Windows 10 machine. The tablet I have been using to run my X-carve has Windows 10 Home. I’ve “installed” the new Easel Local driver and attempted to connect with multiple different web browsers to no avail.

So, I open Easel. Export the g-code. Open UGS (Universal G-code Sender) and run the code. Eventually I’ll stop even using Easel to generate the g-code.

Inventables, congratulations on self deprecating your “software” (web page) ensuring I’ll never pay for Easel “Pro” ever again.

Despite the misleading title, new update is not “bricking” any machines. It is working as expected on software supported by the OS manufacturer.

Easel and Easel Driver supports Windows 10, MacOS 10.15 Catalina and Ubuntu Linux 22.04 or newer operating systems as of writing this post. You can check the current requirements on the Easel System Requirements page.


From my understanding, a software update that takes a working device and leaves it in an non functioning state is pretty much the definition of ‘bricking’.

Easel and x-carve no longer function, to ‘unbrick’ my xcarve i would need to buy a new computer. I cannot update windows, some hardware connected to that machine doesn’t have drivers for the latest version of windows, which is how the world works and is expected.

What’s unexpected is that you would turn on your pc, be forced to update a program putting it in a state where the device no longer functions and have no way of reverting it to the previous working state.

I apologize if I am harping on this, I have an ok understanding of technology. I am not some lone woodworker with an old computer, I am actually director of technology at one of the largest software companies.

It should be noted that at no point previously was this statement made. This is a new claim you are making.
Easel continues to work with the X-Carve cnc, your issue is specific to the PC involved in the setup, not Easel, nor the X-Carve cnc machine. Easel and the X-Carve will function together just fine, so long as you’re running a supported Operating System of course.

Based on that Note about legacy drivers being available, you might expect that this would actually house those legacy drivers:

But unfortunately the legacy drivers are not present on the page that opens when clicking that link… (Inventables should provide those legacy drivers here or remove the link because the text of the link is quite misleading…)

Ultimaker Cura is one of the top players in the 3d printing slicer landscape… it looks like they are windows 10+ now too

Also it should be noted that Javascript is how Easel runs on the users PC… and it’s only showing Windows 7 and 8 on this list for archival purposes per the note at the bottom of the list…

Unfortunately this understanding is inacurate. The device (cnc machine) is fully functional as intended. It is the users operating system that needs corrected if you need to use Easel to contol the cnc machine. Swap that device over to a computer with a supported operating system and it functions fully. Thus your situation is not a bricking occurrence. Or use a differrnt gcode sender that isn’t reliant on Java. Openbuilds Control, UGS, Candles, Gsender, Picsender to name a few would all suffice to get you able to contol the cnc using windows 7.

1 Like

Hi @SethCNC

Based on that Note about legacy drivers being available, you might expect that this would actually house those legacy drivers:

Thanks for pointing that out, we missed this line in the support article when we did clarifications to what is and isn’t supported on July 25th. Support article has been amended to reflect most up to date information.

1 Like

@SethCNC Even installing legacy drivers doesn’t work. The software was changed to drop support for their own working legacy drivers.

Your example of Cura, on their site they have years worth of legacy software and drivers. They have not made any decision to abandon users like Inventables has here.

These shenanigans are not the norm in the software industry. The idea that any printer, inkjet, 3d or cnc software manufacturer could send a mandatory update to turns that software off on a system, making the device unusable… it’s related to Inventables’ need to operate live software in a browser and their decision not to offer a legacy backend or back compat for users.

Big assumption on y part, but as they would rather split hairs on the word bricking and not actually answer the simple questions about why their software no longer works.

It’s easy to point to Microsoft and say their hands were tied, but that’s also a complete mischaracterization. I have three windows 7/8 machines running many devices in my shop, in my office, all still work fine with the same drivers and hardware they have had for years.

Sorry for my rant, I was able to finish my wedding anniversary project on time by moving a modern laptop into my shop temporarily. The idea of a lenovo P1 gen5 with 128GB of RAM and an RTX being used to operate a hobbyist CNC in a dusty shop feels completely stupid. Like hammering nails with a Howitzer.

I’ll look and see if I can use some other software as a sender to the x-carve and ditch Easel.

I think the point is being missed that Easel isn’t standalone software that can be run on a PC without internet access. If that was the case you would be correct to use older software on older PC’s and be fine. I wouldn’t do it if any device was connected to the internet and in fact Windows 7 security updates have been suspended since 2020 so if you have any devices running it for a business and connected to the internet you are at risk of being hacked. Having firewalls I maintained in the past I could watch logs of continued traffic trying to break into my system from outside on a minute by minute basis.

I have Windows 10 Home, with no other software, it only run Firefox and Chrome to run Easel for my XCarve. And I cannot get the driver to install. I meet all the requirements and it has run like a champ until Driver 0.4.0. So telling me it works, when clearly it does not, is not a “Solution”.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.