Easel won't recognize 1800 mm expansion

I’m not sure if I’m doing something wrong or not. I extended my machine to an 1800 Y axis. Not I’m trying to carve an 11 X 54 inch board with cutouts for speakers. I have it drawn up in easel to specs. However when I hit the carve button, it seems to leave off the top cutout for the 8" speaker.
My machine is not 1000 X 1800. I’m wondering if I need to use a different G code program to send it to the machine since easel only goes up to 1000 X 1000. And I have no experience with those. Anyway, any help would be greatly appreciated.

You should be able to set the size of you machine in the settings to whatever size you want. Can you share your Easel project?

Check your machine settings in advanced.

$130=290.000 (x max travel, mm)
$131=290.000 (y max travel, mm)

It maybe that you are trying to tell it to go past the max.


1 Like

Hi Rusty,
Okay, I shared the project. There are two. Khanspire Right and Left. One is just a mirror of the other. I don’t know how to set the machine settings. Where is that?

Hi Andy,
Thank you. But where will I find these settings?

In Easel, Go to machine->Advanced->Machine Inspector In the settings window will list all the current grbl settings. You can change a variable by typing the new value in the console window.

so to change you y max travel, you would type $131=XXXX , where XXXX is your new maximum travel. Not sreu if you have limits etc enabled, but worth checking.

You are going to have to provide the link to the project, but it sounds like you probably just need to change your work area under Machine. Make sure you are setting it to your workable area, not your rail size.

Hi Rusty,
I set my work area or board size in both places. Under materials and machine. Both are set at 11" X 54"

Have you gone through the Easel Machine set up? Setting the size there might actually change the settings on the Arduino.

Hi Rusty,
I did setup the machine as you are asking. I just went in and changed the $131 setting as Andy mentioned. I will try that out tomorrow. I have to go get another sheet of MDF as I am short on material now. I hope this works. I will find out tomorrow.
Thank you everyone.

1 Like

Good Luck!

Well, after all that its still doing the same thing. Its starting the carve on the center cutout up at the top of the board and skipping the two top speaker cutouts.
I’m open to any suggestions.
Here is a screen shot of my machine settings

Have you attempted a different project?

I just ran a project from another older speaker I made. It was a lot smaller than this one but it came out just fine.

You consider problem solved as of now??

A tip would be to draw up a large square or something in Easel and just air-carve the thing to see if the tool moves into the additional work area your axis upgrade added…

The problem is far from solved. I just started a new piece and its way off. All over the place. I’m about ready sell it for scrap alum.

Can you jog your machine to it’s extents?

Sorry to hear that.

Sadly, I do not have any great tip to give you to fix the issue.
It just occurred to me reading this thread that I would start out tinkering without material until I knew the machine recognized the added work area.

Try adding a pen to the machine and put some paper on the waste board and start a new Easel project with some shapes that should cover most of your available work area. A picture might help someone less of a noob like me to figure something out.

Don’t ruin material until this problem has been figured out!

Hi Rusty,
I can jog the machine to all 4 corners using the tabs in the “Carve” area.

Hmm I’m try another Easel project that cut in the areas you’re having difficulty with. Are you able to share the link the project you are having issues with?

When you are on the project you are having issues with, if you click the show tool paths in the 3D viewer area, does it show paths to all of your elements?