Engraving Stops

Hi everyone, I’m trying to engrave a .5mm aluminum plate with a depth of cut of .1mm on a 30X18 3rd Party machine. The problem I have is my engraving stops at about 15% of the way through. I have had this problem in the past and it was due to my internet cutting out. I fixed that by hard-wiring the internet connection instead of using a router. This time I tried checking my computer was not falling asleep and that the USB connection was changed in the control panel as suggested by this site. I have also changed the USB connection cable to a new one. I have also redone the artwork in case the g-code had become corrupted. I even tried another job that I had done in the past and all of these tried remedies had the same result. Negative…Mostly it stops at about 14% but it has stopped at 7% on another job. I don’t know what to try next any help would be very much appreciated.

I would also like to add to this post that I have also discovered in the machine inspector. that Easel is having trouble communicating with the machine. This has not been a problem in the past as I have done several jobs without trouble.

Is your USB cable routed next to some power cables for something?

Are you starting/stopping any large equipment that is on the same circuit that the machine’s controller is powered from during the carves?


Brandon R. Parker

Hi Brandon, Thank you for replying so soon. There was a four-piece power board not far from the USB cable and I moved it to make sure that was not the problem but it was doing the same thing before that got moved there. There is no large equipment on the same circuit board that I know of but will check that out further. The only other thing I can think that might make a difference is that I changed over from Windows 7 to 10 some time ago maybe something there.

Hi Brandon, I have moved the electrical board well away from the USB cord and ensured that no other large equipment was on the same circuit. I was concerned maybe the a/c unit might have been on the same circuit so this morning I ran the machine again with no a/c on and had the same result of about 17% through the job. Only this time I did it in the air. I mentioned in my earlier post that the machine inspector reads Easel is having trouble communicating with the machine, could this be a clue? regards Col

After trying another job the same thing occurred so I checked the Machine inspector and it read Error 8. Does that through any light onto this problem? regards Col

I can’t say that I have ever personally encountered that error.


There are a few possibilities to check…

  1. Windows has some nifty (read as painful) USB suspension tricks up its sleeves. Here is a link that should get you started checking that. You may have to do a little bit of internet sleuthing depending on your version of Windows.
  1. It could be the computer’s USB port, but … not a normal suspect.


Brandon R. Parker

Hi Brandon, I was wondering if you would have a rock large enough to drop on this computer or program. If you can’t guess by my intro, I am still at a loss as to what to do next.
I have tried what you suggested in your last email, and I even tried swapping computers and changing all the sleep modes and USB settings before loading Easel. Sorry to have to write this but it was just the same.
So today I have tried something new. As I wired up my computer again and looked at the machine inspector, it showed nothing in its Little box. I was excited by this so asked it for a report and it ended up saying just as it did before ‘having trouble communicating with machine’.
I ran my little job and it came to a standstill at about 14% through the job as before. So I rang the job again using the same settings as I had done on the first run. It came to a halt on the same spot. Does this mean it is having trouble reading the G-code surely if the machine inspector is detecting something is wrong with the communication that is where the problem arises.
Before I go any further I want to thank you for all the help you have offered and want you to know I have really tried to check out all your suggestions. I am wondering if there is someone at Easel I should ask in case the problem is at their end, what do you think or have you found that rock?
Kind regards and all the best for Christmas and the new year.

Will this one suffice?

You might also try ensuring the USB drivers on the computer are updated…

I apologize, my previous post included something for the X-Controller, and I see that you are running a 3018. I do not have a 3018, but I can check out the project/gcode.

If you can share the Easel file, I can air-carve it tomorrow (Wednesday) night and see if my X-Carve has an issue. Or, you can post/send me the NC file if you wish.

I still think is a USB RFI issue. Have you tried allowing the machine to air-carve without the spindle being turned on? You will have to set your Z-Axis to a falsely high value above any stock or bed to prevent crashing. If the file runs repeatedly with no issues then the main culprit is RFI from the spindle motor/wiring/spindle control.


Brandon R. Parker

Hi Brandon, Merry Christmas mate. Sorry for this late reply, I thought I had sent it to you but I replied with my email notification and of course, it refused to send it. You have to be 70+ to do something stupid like that. So here we go again and hopefully, you get this one. I think I know now how to get to the G-code to send it to you. So please find it attached.
Mothers Day Cup (1).nc (112.7 KB)
By the way, you did a good job finding a rock…well done.
I have had so much trouble trying to fix this I thought I would try FreeCAD and studied that for a long time but truly, I found it too hard for engraving text.
I have been air carving for a long time and get the same result. Also imported the G-code file to UGS and it reported errors in the G-code.
I changed computers and got the same. I also deleted all files that were Easel files and reloaded them…same old same old.
Thank you for all your help, ‘good on you mate’ cheers Col

Merry Christmas to you as well!!

Did you air-carve with the spindle disconnected?

I do not see anything wrong with the file from a quick glance…


Brandon R. Parker

Hi Brendon, do you mean with the spindle not turning when you say disconnected?
I have air-carved with it running.
Cheers Col

Yes, with the spindle not turning.


Brandon R. Parker

Just a thought here, but what is the status of the carve where it fails? Is it at full depth like a through cut when it fails? I have had pieces fail when the Z hits the limit switch, and I have resolved this with an auxiliary wasteboard (or a scrap piece to raise the work up just enough).

Hi Jordan, Thanks for your reply. I do not have any limit switches and I am only engraving at a very shallow depth (.2mm). But thank you for your comments.
Kind regards Col

Hi Brandon, I hope you had an enjoyable Christmas day. I spent it with all my family and we had a great day.
I tried air carving without the spindle turning and I got three different results: 2% 4% & 7%. Stopping.
Did you have time to dry the G-code on your machine?
All the best Col

We had a great Christmas as well!

I have not yet run the gcode on my machine, but I can do that tomorrow morning. I still think it is some type of EMI/RFI event that is occurring. The difference is percentage of completion you just mentioned points to that as well, since there would be no way to get beyond 2% the second and third try if something was wrong with the file at that point.


Brandon R. Parker

Hi Brandon, I’m very happy to write I have finally fixed the bug although I don’t know exactly what was the problem. I ordered another control board ($50) and was happy to pay that to finally get the machine mobile again.
I want to thank you for your help, it was appreciated and again thanks for taking the time to try and solve the problem.
Kind regards Col

Not a problem!!

I am glad that you were able to get the issue resolved. Out of curiosity, do the control boards appear to differ in any way (i.e. different size capacitors or other different components)?


Brandon R. Parker

Hi Brandon, The boards are different so have attached pics of them as I sure you understand them better than I.
Cheers Col