Error in the <geometry

Hi There!

I have a problem when I import the gcode generated from MeshCAM the vertical parts seems to be around 2,5 mm smaller were there is not material and 2,5 mm bigger where there is.

I do not know if it is the MeshCAM or Easel.

Have anyone experienced such problems?

Also, can anyone recomend another CAM for free download that MeshCAM?

Kind regards,
Curt Hallberg

1 Like

You could verify the gcode in … OR on OpenBuilds Control (which can also be used as your gcode sender in place of Easel)

BUT easel doesn’t modify the guts of the gcode, so I’m willing to bet that the issue is from MeshCAM, either a setting issue or just a flaw…

Thank you Seth!
Yes, I am also into that direction that it is MeshCAM because I smetimes get problems that MeshCAM seems o accept narrow passages and sometimes not, but with the same bit and the same STL-model.
I will try to get hold on Fusion and use their CAM system to see if they get it right.

From what you describe, it sounds like the project as viewed once imported into Easel is different from what you designed in Meshcam. You state that vertical edges are larger than expected in areas where material is not removed and smaller than expected in areas where material is removed.

What this sounds like is that Meshcam and Easel have different ideas about the diameter of the cutting tool. Easel is following the correct path, but the tool it believes it is using is smaller than what Meshcam believed the tool to be when it created tool paths.

You might experiment with adjusting the tool diameter in Easel to see if you can correct for what you see.

He’s importing completed gcode… there is no toolpath being created within easel thus no bit selection within easel.

Yes, the gcode is imported to easel and I also observed the same this in ncviewer!
As I can observe it not only in Easel (both at the display and when I mill) but also in ncviewer the conclusion is that the problem is in MeshCAM. What is funny (!?) is that I have milled it out perfectly earlier. I have used the same STL for a month ago and then it was perfect but now when I use the same STL (whith minor changes) the result is different. So, something must have happend in between.
I can see that there is a new version of MeshCAM so maybe sommething happend during that upgrade
I have downloaded trial Autocad Fusion where it is possible to make the gcode, lets see if this works.

1 Like

Before you mentioned importing G-code. Now you mention importing and STL. What is your workflow? STL into meshcam outputting G-code which is then imported to Easel?

Or perhaps you use Meshcam to produce the STL which is then imported into Easel Pro.

I’m sorry, I’m a bit lost.

Hi Harry!

Yes, I am making a 3D model in mu CAD from where I transform it into STL which i import to MeshCAM which is making it into the gcode that is imported to Easel.

So, right now my idea is that it is in MeshCAM something goes wrong so the trajectory o the bit is wrong calculated.

I can see the error both in Easel and in ncviewer. I mean, if the gcode is OK and Easel problematic I could see the error on Easel and when I mill it, but not in both Easel and ncviewer.

But, if the gcode is wrong the problem should be in MeshCAM creating the gcode.

1 Like

So some news from my error…

I have tried to generate gcodefrom both MechCAM and Fusion 360 but I get the same erorr!
I am back that the error is in Easel again.

Whats fun is that when I try to calibrate I first used the methos to measure (with a good stel ruler) and when I typically click 60x10 mm time I do not get a movement of 600 mm but 603 mm both in X and Y.

BUT, when I mill out a test pattern where I mill out hole with a distance of 600 mm (in the CAD) I get 600 mm!

So when I toggle I get one distance and when I actually mill I get the correct distance.

However, I still have the error when I print the different pattern I described earlier.

So in one mill I get the correct measurement and wrong in others. The toggeling shows an error of 0,5% 603 instead of 600.


Some ideas??


1 Like

If you want to share your STL, some of us might be able to produce G-code from your STL file. I do that for my own STL files using V-carve Desktop.

I am openscaddad on Thingiverse and Printables

You can share your STL through the forum, or if you are on Thingiverse, you can place it there and send us a link to the STL.

Hey Curt,
Can you share the Fusion360 Project with me. There is an option to allow the other person to download the file, please select that in F360 when sharing, then there should be a Link you can copy and If you prefer you can send me a DM with the link or an email: and I can review the Fusion360 setup. I’m a lot more familiar with F360 than I am with MeshCAM so hopefully I can identify the issue there. Oh and you can send over the gcode file as well, from the F360 project also.

Also, in F360 are you using the Easel Post Processor? (just want to confirm)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.