ESS and MX3660 question

I’m on Mach 4 with the MX3660 and ESS and although there was a lot of fiddling around to get it all to come together it’s done with one exception. My Z and X axis run buttery smooth but I have stuttering and motor noises during y axis movement. Jogging on Y is pretty good but any programmed movements like homing give me these problems. Haven’t done any carving yet, this is all setup. I’ve doubled the current on the Y axis using the dip switches on the MX 3660 and have tried various settings on the motor adjustment screen on Mach with no improvement. I also gave the folks at Leadshine a call and they basically scratched their head and said they wouldn’t double up two motors on one port and said I should be using their 4660 unit. I’m about ready to try a 4660 but before I take this leap has anyone else done this setup and maybe have a suggestion?


As always check belt tension and v-wheels. (And keep checking bet tension It will loosen up a bit after the first carve)
For the Y axis make sure you have the motors weird correctly. One motor will had 2 of the wires reversed so that it mirrors the other motor’s direction.

Thanks Aaron. This is an XCarve that been used for a while using my grbl and the mechanics are in good shape. Y motor wiring is good too. I think there must be a finicky setting or two in either Mach 4 or the 3660 that I’m hoping someone has come across. Once it all comes together I’ll outline the entire conversion process for the forum.

Yeah, the two motors on one port is the issue. You’ll need to bump up the power in the settings somehow. Either that or rewire the two Y steppers to be run by two separate slaved ports. Hence the recommendation to bump up to the MX4660.

You may be able to set the RMS to what you need using the DIP switch for the Y Stepper, referring to this chart found in the manual:

As a test, Remove the secondary stepper on Y and test, then do the same for the primary. Then I’d move the connector from Y to X and X to Y and see if you get the same issues.
If you are (and X & Y both have the same values for steps per mm/inch) then you need to check the dips on the MX3660.

If swapping works but paired it does not, then the other option is adding an extra external driver to handle Y2. This depends how many ‘features’ you’ve enabled. i.e. MIN/MAX endstops, Probes etc… If you have the basic setup (only homing switches only for example) A external driver could be added without upgrading to the 4660. You can get any external driver i.e. the ST-5045 and use the output (+) 1 & 2 for step (aka pulse) and direction. Then you’d have to configure Mach to use those pins as a ‘A’ axis. then with-in mach configure A to mirror Y. Depending which side of the gantry Y2 is on, you may have to set up as reverse.

Well folks…after all of this effort and some excellent recommendations from the the community the problem was a poor connection on the Y axis terminal block where the two motors merge their wiring. I had flipped dip switches all the way up and down the options, switched axis ports on the MX3660 and even reconfigured my Mach profile to an alternate ESS port. Nothing helped until I noticed one wire wasn’t seated on the terminal very well. Fact is our little grbl board and the stock power supply drive both motors fine so really the MX3660 with the beefier power supply should have as well. Or at least that’s how my primitive logic sees it.
I’m happy to say now Mach 4 on Win 10 with the stock configurations on both the MX3660 and ESS along with our stock limit/homing switches and the probe feature are all working fine. Mach 4 soft limits handle the opposite ends of the axis. There is a bit of fiddling with the Mach 4 motor calibrations to get it dialed in but if you’re interested this guy covers it very well

I’m using LinuxCNC and having the same issue X and Z are amazingly smooth and perfect, while the dual Y makes some weird noises. Check my connections, all are tight. I’ve tried turning the DIP switches up, but that doesn’t seem like a logical solution since the motors are wired in parallel, the voltage doubles, not the amperage right? I don’t have homing hooked up or anything else, just the motors.

I’ll give @ymilord’s test a shot once I finish configuring a few things.

I figured it out, I thought the DIP switch for resolution was set right, but it was like half way between ON and OFF. Fixed that an no more stuttering, everything runs smooth!