Feedrate recommendations for wood

Do any helpful carvers feel like sharing some of their favored feedrate settings for wood? I’m using Meshcam to process my files, and its default “fast” settings for roughing are:

.254 mm - depth per pass
2.54 mm - stepover
127 mm - feedrate (which translates to about 5 ipm!)
127 mm - plunge rate

I’m losing years off my life just trying to get through roughing! :grinning: Going to Google and searching through here revealed that calculators and recommended feedrates are numerous for metals, but it seems like wood is something of a mystery (or perhaps just left to trial and error). About the best I found on one post here and one website was a range recommendation of 320 - 590 ipm for soft woods. If it matters, this would be using the 2 flute spiral upcut (6.25 mm) that came with my X-Carve and the Dewalt 611.

With a 0.25 inch endmill roughing pass in soft woods I usually use

60 IPM (1500 mm per minute)
0.08" depth of cut (2 mm)
stepover 20%
plunge 45 IPM (1150 mm per minute)

with my Dewalt speed set at about 1.5

1 Like

Thank you very much for the recommendations! :slight_smile:

1 Like

Collected list of feed-speed rates for various sorts of woods here: http://www.shapeoko.com/wiki/index.php/Materials#Wood

Note esp. the testing technique linked to further up that page: http://www.precisebits.com/tutorials/calibrating_feeds_n_speeds.htm

more great info, thanks! One question, when you guys say “40% stepover,” you are referring to 40% of what setting?

40% of bit diameter
VCarve and other programs can use % of diameter for stepover.
I use 40% for roughing, 10% for finishing.

So 40% of a 0.25" bit is 0.1 inches or 2.54 mm.

Thanks, Erik and Aaron. I just realized the simple conversion right before I saw your replies. My early morning math skills are a little weak!

1 Like

I’ve had my coffee, so I am good.

Sorry for the dumb question but what is Stepover?

Mmm mine is default setted on 40%. Is that wrong?

It all depends on type of bit and surface finish you want. On my lithophanes, I use a tiny ballnose bit with a 15% stepover for a nice smooth finish.

3D carves I use a 10%-20% stepover for detail/finishing passes.

For pocketing in wood I used anything between 20% - 40% for endmills. Smoother finish for smaller stepover, but increased time.

Mm I understand what is. I’ll do some test to see the difference.

Another silly question: Is possible that UCGS or GRBL controller have messed up my settings?

EDIT: If I carve something with Easel (pretty much to make template I send a SVG file to Easle because I found it faster) when I have to check the Z position, if the material is secure etc there’s a section where it ask something about steps. Is default setted to 0.1, is that correct?

Testing is your best bet to see what is best for you.

It is possible, you can change the grbl settings with Universal G-Code Sender, I have no idea about GRBL Controller.

Do a $$ command to see what your settings are. You will need something to compare the output to. I am pretty sure the standard/default settings are here in the forum somewhere. I am not at my CNC so I can’t check mine.

Definition of Stepover at: http://www.shapeoko.com/wiki/index.php/Glossary#S

(but w/o the nifty diagram which ErikJenkins posted)

There is however, a link to: http://www.cnccookbook.com/CCCNCMillFeedsSpeedsStepover.htm

2 Likes

Thank you, very interesting reading! So I guess 40% will automatically be setted when I select MDF in Easel, for example.

I guess I need to start using Aspire 8 as I have it. But need to check if my grbl default setting was not messed by UCGS or GRBL Controller.

?
What default settings?
Are you referring to cut depth and width of cut (step over)?
These are settings in the CAM (Computer-Aided Manufacturing) software used to generate the G Code. (in your case Easel or Aspire)
They are not in GRBL. GRBL is a operating system that runs the gCode.

Note:
CAD (Computer-Aided Design) software is used to make the design
CAM (Computer-Aided Manufacturing) software used to generate the G Code - usual a “Post Processor” file is used to format that G Code for a specific machine.
Some programs, like Easel combine both of these functions (CAD and CAM) into one.

If you are having issues with your G Code generated by Aspire it may be the specific “post processor” you are using.
I know with VCarve I had to make a few adjustments to get it to work properly with UGS

Well, thanks for the lesson, always good to learn something.

I exlpain you what I did. I tried to make some toolpath with Aspire, that I have never used before. Generated it with grbl (mm) post processor.

Loaded it on GRBL Controller first but not worked, then UGCS. It worked. I mean, Toolpath were messed but I could control the machine at least. Of course I either never used UGCS before so that’s why I tunerd back to Easel to do basic template, but after that I noticed some difference in the machine movement. Is possible that GRBL Controller/UGCS have changed something?

UGS is in constant development. I use the daily build version.
Early on I also updated the version of GRBL on my GShield. It was a major hassle to do as the instructions (at the time) left out a few critical steps. But I don’t know if you actual need to do it or not.

The most common cause of weirdness is a units type mismatch.
You have to make sure you use the right post processor, inch (G20) or mm (G21), to match the units you designed your project in. Getting these modes mismatch can result in things being 25.4 time bigger or smaller than expected.

Another potential cause of weirdness is addressing mode.
Absolute Addressing (G90) is the position from zero. So X1 is 1 unit from zero, X2 is 2 units from zero, etc.
Incremental programming (G91) is the change from the previous position. So, if we start a zero, X1 is 1 unit from the previous position (1 unit from zero), X2 is 2 units from the previous position (now 3 units from zero), X4 is 4 units from the previous position (now 7 units from zero), etc. Getting these modes mixed up will result in things rapidly going crazy.

It is important to note the UGS uses Incremental programming (G91) commands when using the manual machine controls. So I make sure my g-code files all have a “G90” at the beginning, just to make sure

Also the X-Carve post processor has a tool change command in the header. But as the XC does not have a automatic tool changer this does nothing (I think this is just a way to reference which bit to use in the G-code file if you manually read it later.)
This can sometimes cause UGS to go wonky, so I removed it form my post processor.

Here is a copy of the mm post processor I use for VCarve.
X-Carve_(mm).pp (4.5 KB)
It should work with Aspire as well.
If it is anything like VCarve, you can access the post processor folder by click on “Open Application Data Folder” in the Aspire “File” menu

1 Like