[FIXED] Cannot connect to X-Carve (Mac or Windows)

I first thought this was a Mac-only issue, but I was able to find a Windows10 laptop and still cannot get my computer to do the Easel setup.

  • I’ve tried rebooting both machines (also tried on a 3rd Macbook Air)

  • Tried Chrome, Firefox, and Safari

  • Unseated and reseated gShield 3 times (making sure it’s firmly in place)

  • Put electrical tape on metal in case it was touching

  • Mac, Running OS 10.10.5 Yosemite

  • Windows, installed Arduino software

  • Easel Local installed on both machines

  • When USB is plugged in, Green light comes on on gShield. When run Easel Setup, that light flashes on/off in a short/long/pause pattern. When the green light is on, it’s extremely difficult to manually move any axis

  • Tried installing Arduino Mac App and following the steps to compiling GRBL and get

    avrdude: stk500_paged_write(): (a) protocol error, expect=0x14, resp=0x10
    avrdude: stk500_recv(): programmer is not responding

  • Tried running the Blink example from Arduino and get same error

  • Only serial options in Arduino app (I selected the 3rd one assuming that was it):

  • Tried HexUploader (following these instructions from Inventables) and does nothing

Here is my wiring connections and setup:

Help!

I can’t help with the MAC portion.

With the USB cable plugged in, and the 24 volt power supply turned on you should have the blue LED and three green LEDs lit up.

You mentioned trying to run the blink test program. Doing so will remove the grbl code so to get back to grbl you will have to reload it.

Your serial port needs to have a baud rate of 57600 to use the bootloader on the Arduino, but it needs to be 115200 for talking to grbl.

Thanks. After trying to do the GRBL compile, the 3 green LEDs no longer are on on the gShield.

I also just took the PC and downloaded XLoader, and did:

Device=Uno(ATmega328)
COM port = COM3 (only option in dropdown and is correct according to Device Manager)
Baud rate = 115200

When I click Upload (using the one from the Inventables Grbl page, the XLoader output says:

Can't open port

Set the baud rate in Xloader to 57600. Also on COM3

Steps I just took:

  • Reseated gShield
  • Plugged into different USB on PC
  • Open XLoader
  • same settings as previous post, and got
    28054 bytes uploaded
    and green LEDs are back on!

Then:

Back to where I started. The green LEDs flash for a second, then flash for a longer period, then a pause.

The PC is stuck on the

Enter the COM port your machine is connected to

screen

Now change the baud rate on COM3 back to 115200 so you can talk to grbl.

Sorry, meant to say “XLoader settings as previous post” was referring to my previous post. Ran Loader at 115200 Baud Rate and it uploaded correctly.

Just rebooted PC and X-Carve electronics, and now the LEDs flash really fast, but still cannot get past Easel Setup

Do you have HyperTerminal or Putty?

This is my first time ever shaking hands with an Arduino or CNC machine. so I’m not sure what those programs are.

Short answer, no. I do not have those :smile:

1 Like

Basically it is just a terminal program for talking to a serial port.

I was going to try to see if we could talk directly to the Arduino to try and isolate the problem.

Actually, you said that you tried to run blink. Does that mean that you have the Arduino IDE loaded on your PC? It has a serial monitor we could use.

Just as a guess, some people have had issues with the USB connection. If you have a powered USB hub try plugging your Arduino into the powered hub and that might solve the problem.

Yes, I have the app from the Arduino website installed on my Mac and Win10 machines

I don’t have any powered USB hubs. Just the USB plugged straight into the computer

Ok, try to bring up the Arduino IDE and look at the top right corner there should be a magnifying glass icon. That is the serial monitor.

Check under the Tools menu item to make sure that you have the Arduino Uno selected and the COM port for the Arudino selected.

Press the magnifying glass and the serial monitor should come up.

If everything is Ok and the USB cable is plugged into the Arduino you should get a message from grbl telling you the version number. If you don’t, unplugged the USB cable and plug it back in.

Enter the command $$ in the serial monitor window and grbl should list out its parameters. Copy that output and post it here.

  • Plugged in USB and turned on X-Carve power supply
  • Opened Arduino on Mac
  • Clicked Magnifying icon
  • Nothing listed, tried plugging USB into other ports. (when I plug the USB into the Mac, the green LEDs flicker once and I hear the stepper motors make a “click” noise

Still just shows:

The green LEDs should be on. Where did you get the grbl hex file to load into the Arduino?

Make sure that the gShield is plugged into the Arduino with the mounting pins lined up. It’s very easy to plug it in with the pins mis-aligned.

At the bottom of the serial monitor window change the “No line ending” to “Newline”.

It appears that you are having com port issues. Is there a way on the Mac that you can check the health and properties of the COM port?

When you changed ports, did you update the IDE?

The values in this output are not correct for the X-carve, but just show the type of display you should get.

followed this: https://inventables.desk.com/customer/portal/articles/2069033-grbl

for getting Grbl back on

After changing “No line ending” to “Newline” it still does nothing in Arduino app.

When I tried to use that .hex file it would not work for me.

What I did was follow the link to the source files;

When I did this it worked.

Just came home for lunch break in an attempt to call Inventables, but the nice receptionist said all techs were busy so I had to leave a callback number.

@LarryM I just followed your steps (from my slow PC) and was able to do those steps to get Grbl uploaded. I then quit the Arduino app, opened Firefox and went to Easel Setup, and I got one step further!

After clicking Confirm Settings, putting in the port number (doing this from the PC for now) it now says “Configuring Z axis for ACME…”

But now it’s been sitting on this screen for a while. I also heard of people with Firefox problems, so I opened the setup in Chrome and had the same results

Also, as previously requested, I now could do the $$ command in the Arduino app and got the below code:

Grbl 0.9j ['$
Grbl 0.9j ['$' for help]
['$H'|'$X' to unlock]
$0=255 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=255 (step port invert mask:11111111)
$3=255 (dir port invert mask:11111111)
$4=1 (step enable invert, bool)
$5=1 (limit pins invert, bool)
$6=1 (probe pin invert, bool)
$10=255 (status report mask:11111111)
$11=2147483.648 (junction deviation, mm)
$12=2147483.648 (arc tolerance, mm)
$13=1 (report inches, bool)
$20=1 (soft limits, bool)
$21=1 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=255 (homing dir invert mask:11111111)
$24=2147483.648 (homing feed, mm/min)
$25=2147483.648 (homing seek, mm/min)
$26=255 (homing debounce, msec)
$27=2147483.648 (homing pull-off, mm)
$100=2147483.648 (x, step/mm)
$101=0.000 (y, step/mm)
$102=0.000 (z, step/mm)
$110=2147483.648 (x max rate, mm/min)
$111=0.000 (y max rate, mm/min)
$112=0.000 (z max rate, mm/min)
$120=2147483.648 (x accel, mm/sec^2)
$121=0.000 (y accel, mm/sec^2)
$122=0.000 (z accel, mm/sec^2)
$130=2147483.648 (x max travel, mm)
$131=0.000 (y max travel, mm)
$132=0.000 (z max travel, mm)
ok

Edit: Just tried on Mac. Get the same results. Can now do $$ in Arduino and get a response, and Easel Setup now gets to the Configuring Z axis for ACME… step

Still no green LEDs on, though

Good. We’re talking to the Arduino now. The parameters are all garbage.

Enter the command $RST=$

This will reset the values in EEPROM to the settings that Inventables uses for the X-carve.

Re-post the $$ settings after this is done so we can see if it worked.

Grbl 0.9j ['$' for help]
['$H'|'$X' to unlock]
$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=0 (dir port invert mask:00000000)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=250.000 (x, step/mm)
$101=250.000 (y, step/mm)
$102=250.000 (z, step/mm)
$110=500.000 (x max rate, mm/min)
$111=500.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=10.000 (x accel, mm/sec^2)
$121=10.000 (y accel, mm/sec^2)
$122=10.000 (z accel, mm/sec^2)
$130=200.000 (x max travel, mm)
$131=200.000 (y max travel, mm)
$132=200.000 (z max travel, mm)
ok