Flex issues

Pretty well have everything squared thanks to a PDF I found. Still a slight difference in the X axis being squared in relation to the Y axis. When I slide the X axis gantry all the way to the front of the Y axis rails it touched the front end plate on the left side, but is 1/4" from touching on the right Y axis end plate. Earlier it was closer to 1" difference.
While messing with this, I barely pushed on the right end of the X axis gantry and it flexed forward 1/4" or more. Almost no effort at all, and it flexed that easy. I have a 10 second video clip to demonstrate

Check settings
$1 should =115
Upon rereading a lot more slowly I have a question. Do you have a single x? What xcarve version do you have?

I don’t have anything set up as far as software or running the machine yet. I’m slowly going through setting it up right the first time and noticed this flex and wanted to correct it before running the machine.
I have the 1000mm machine.


It’s not software or Firmware issue. It is mechanical.
Some guys adding thin shim to between Xrail and holding plate, some guys like me using same length piece of Plexiglas/wood or similar piece in front of Axis on both end then pulling all the way front to bump stop. When you turn your machine on, steppers locks in place and you’re square. put those pieces a side use it next day. It will be needed after you turn your machine off.
I do this everyday before start working.
Check the plastic piece between end plate and Y stepper plate.

1 Like

Correct. I was half asleep lol.

1 Like

Just got what you were trying to say. Was half asleep.
If your motors are wired up and connected it should be a little extra difficult to move. But if the gantry twists a little while powered down it’s kinda normal and it’s kinda expected if u have the 2 x vs single x.

Other option is you may have something a drop loose like some v wheels or even the rail screws.

I agree ^ however i did something a little different. Before I upgraded to my current setup I used the quoted technique to square up my machine before powering up. Once powered up the steppers locked and held itself square.

Then I brought the gantry all the way to the front carefully and got it as close as possible. Once my limit switch screw was resting against the gantry plate I added a second screw on the other side and that was locked flush to the gantry plate as well. So no more pieces. I just held my gantry against the limit screws and that held it square.

1 Like

Thanks for the advice. I’ll go ahead and get everything assembled completely and try to square like mentioned on start up. I’ll report back once I try that method. Should have it all assembled by this weekend and running.


Awesome. Hit the threads if you need help.

1 Like

I too added the extra stop at the end of the of the travel. It solves the squaring problem but creates another. On my X-Carve if the gantry is against the stop “Homing” will fail every time. It appears there needs to be some movement for homing to work and being against the stop prevents that. Back away a little and it homes fine but then is may well be out of square. Am I doing something wrong? If not the individual spacers AlanDavis suggest maybe my best bet.

It’s all about positioning the “stop” screws and spacers in the right place. And if there is an issue raise the pull off from 1 mm to 3.
Check ur $$ it will be labeled.

That solved the problem! Changed $27 from 1.0 to 3.0 and homing completed. Thanks!!!

$27=3.000 (homing pull-off, mm)

1 Like

That’s what we are here for. Mark this thread solved.