Frustrations with random machine stoppages

So I was just posting earlier about how I thought that I had all the bugs worked out with my Xcarve in response to someone else that was having some frustrations. And now I’m having issues again. I ran the thing all day Saturday doing carvings in cedar. No problems. I worked in the shop with other tools didn’t shut down once.

Fast-forward to Sunday. Had to run the same piece 6 times because the machine would just randomly stop. Tried with manual spindle, auto, didn’t seem to matter. I had experienced some issues previous with auto spindle control doing some weird stuff was suggested it was EMI/EMF problems. Took some tips from others and thought I was past that. So, Sunday I cut in a whole new circuit in my shop that has NOTHING else on it. Seemed to work ok after that.

Fast-forward to today. Put a piece in machine runs for about an hour on this carve, I use my mitre saw, which is on a different circuit shuts down. Try to restart it on auto spindle and router flashes on and off and shuts the carve down. The carve logo in the top corner in Easel goes blue. Go thru this a half dozen times, switch the relay to yet a different circuit and it starts up and goes. Use my jointer on the other side of the shop on a different circuit than either the Xcarve or relay, machine stops!

Is this a distinctly XCarve issue? Is this a relay issue? Frustration is mounting quickly. Ran it all last week with no problems until Sunday and now it’s a gong show. I’m considering upgrading to a larger size but am wondering if I shouldn’t be rid of the Xcarve and go to a Longmill, or Bob’s, Shapeoko? Or is this a problem for all of these units?

Very frustrating and time consuming, and is taking the fun out of this in a hurry!


Is it worth trying a power line filter?

1 Like

So today I leave the machine running in the shop and leave. I come back several hours later and find a carve that was not quite complete. Open machine inspector and it’s in ‘Alarm’ state but spindle is at home position that I started the carve at.

I question if this is a limit switch suffering from EMI. The wiring to the switches is not shielded, I moved some stuff around cleaning up the other day and wonder if the wiring for the limit switches is picking up some interference now?

Thats one plausible possibility, another is soft limit violation. What are your $20 and $21 values set to?

Regarding running a CNC unsupervised - be careful:

1 Like


Unfortunately it seems the best chance I have at finishing a carve is if I’m not in the shop. I prefer to be out there working on other stuff so I can keep an eye on it but it seems this is when I’m having the most trouble with stoppages. I don’t have the time to sit there and watch it and not be doing something else.

This brings a thought to me… perhaps I’ll hope the machine and then disable hard limits to try and narrow down the possibilities of what is causing these stoppages.

I find the switches invaluable right now as they are saving a lot of work that would be nearly impossible to get back to same origin otherwise after a shutdown.

Thanks for your reply hopefully I can get this narrowed down.


Do you have homing switches? If you do, or add them you can have a consistent work zero between power cycles as a homing cycle sync machine space to model enviroment. And work zero is stored as an offset relative to machine zero. It also open up the possibility to use parking spots G28 and G30 :slight_smile:

Yes I have the switches… I don’t think I could manage without them… so many stoppages. I generally carve the same stock over and over again, so G28 and G30 is very useful for me…

I actually discovered today that my firmware was quite out-of-date 1.0c. I’ve updated to 1.1g and hope this helps resolve some of my issues.

Since you use hard limit switches - disabling them is one thing I’d certainly do while troubleshooting, even for a prolonged period of time if needed.

A - If the steppers dont loose steps (running solidly in that regard) machine zero and soft limits enabled/set correctly will prevent crashing. This will have zero impact on any RF-noise / interference issues.

B - Hard limit switches add several feet of often poor wire (in terms of shielding and noise rejection). Many dont put filtering caps on them either, another hole in the fence.

C - Chasing down the cause for RF-noise can be a real headache, and eliminiating one source at the time will hopefully lead you to the culprit eventually…sooner rather than later hopefully.

USB is a weak interface and it only take a ms of interrupted signal for the link to loose connection. This is common for most USB-based controllers.

You got the Xcontroller right?
Try bypassing the front panel USB connector, connect directly to the MicroUSB found inside. There have been issues with some IIRC.

THE same things is happening to me right now!! I just saw this and will read the 8 replies, but I no nothing with code, so I hope there is an answer! Mine is when I turn on the vacuum to suck up the dust. I have to run it without the dust collector, and this does not work for me. 8 times on a SQUARE.

Sounds like you are getting electrical enterferance when your dust collector is running. Make sure it is plugged into a seperate circuit. You can also get static electricity form the hose which can also cause a problem. You may need to ground the hose.

I had it grounded, but when I purchased my Vacmaster wall mounted it stated it was already grounded, but I will do this, just to be safe.

Im seriously ready to toss my machine out the window. I had this running over a year without issues. Now it won’t complete a job. Just stops and losses the connection. Unplug usb plug back and its up. then stops again.

Checked / replaced the router brushes?

Hello and thank you for your help. It’s not the router, the controller or easel simply turn it off and stop sending code. Luckily I used a great starting point to be able to restart the jobs. But it’s time consuming when you think the job is done on one machine and it’s not.

The weak link for any GRBL controller is the USB-connection.
RF/EMI noise can easily be picked up by the cable and interrupt the USB-link, causing the controller to stop.

Easel dont “turn off” sending code
Controller, if healthy, will not stop recieving or pocess code unless its detect bad commands.

An interrupted USB-link will stop code, tricking the controller into thinking its done / or simply halts it.

  • Inspect the brushed of your Dewalt, report back the length of each (there is one pair).
  • What speed setting do you run the Dewalt at?
  • Do you have an externally powered USB-hub you can try? The external power provide a stronger noise-rejection chain.
  • If you have the Xcontroller, bypassing the front panel USB-port might also help. (several had issues with is in the past)

Winter usually = dryer air => risk of increased static issues. Static can kill USB-connection in an instant.

Troubleshooting can be tedious and frustraiting, but one by one eliminating potensial issues may eventually solve it. I would start with the brushes :slight_smile:


As usual with this topic I will pitch in with my list regarding my measures. :slight_smile:
Also I’m strongly supporting @HaldorLonningdal in proposing the step by step procedure, since it was the only thing rescuing me when I had the same problems.

1 Like

The router will continue to run with bad brushes…
However those bad brushes cause electrical noise that interrupts the connection to the controller and stops the carve. That is what Haldor is referring to.

So i replaced the brushes, they were close to the end but not completely used up. I had thought that Microsoft Edge weas the cuplrit, but since my other Xcarve is using Edge with no issues, that did not seem to fly. But I’m using Chrome anyway for testing. What seems to be working is that I must keep the browser window in the active foreground. I can switch to Lightspeed for lasering quickly but have to return to the browser window to keep the carve going.

All my power settings including those in device manager have always been set to no sleep, full power and no power management. Also to know that the machines have thier own breaker and have been in this setup for 3 years with no issues until recently.

Still working on it but at least I can get orders moving again on machine #2.

Thanks for the suggestion as I will run through them again.