Fusion 360 -> UGS -> Xcarve 1000 workflow issue

Im not 100% this is the spot to put this, but here goes…

I am a new owner of an xcarve 1000, and completely new to the CNC scene. being an IT guy, i built a simple computer to connect to it and installed things like fusion 360, inkscape, UGS (2.0), and the easel drivers.

in Fusion, i have downloaded and installed the post files for xcarve and easel. I have created a project to engrave a surfboard and letters into a guitar.

I created the gcode and uploaded it to UGS. It looks right, but the tip of the surfboard is 2 inches too far to the right, and the z axis never went down (should be a 1/16 deep cut). i ended up lifting the scratch board that im trying this out on, to see what was being cut.

in UGS the x and y values should be 0 i think, they are -29 (-750mm). even after I hit reset zero, it still shows -29 underneath the bigger number for x and y.

I calibrated the machine using a caliper and the wizard

I have attached as many pics as I can to help illustrate what I have done. where are my errors stemming from?

2Annotation 2020-02-27 100814 Annotation 2020-02-27 101726

Do you have home switches? Did you home it? Does it then show negative numbers after homing? This can be an issue, as it is with mine. I end up just closing the UGS and reopening it without re homing it a second time. This is because traditionally, cnc machines had home to the far right, not the near left like the X carve.

I do have homing switches, and yes they are negative numbers when I home. I have tried to disconnect and reconnect but without closing UGS. I just tried at now I see 0s. that resolves that.

the issues left are it going 18 inches to the right instead of about 15.5 inches, and the bit staying at Z 0 instead of plunging into the wood.

1 - How do you set your work zero in UGS?
My workflow is as follows:

  • Power machine ON, command $H to do a homing cycle (this syncronise machine coordinates with design coordinates)
  • Jog to my intended work zero position (Click Reset Zero)
  • Send gcode to the machine and carve

2 - The negative or positive figures are arbitraty and can be ignored. As long as the machine have performed a homing cycle any set work zero´s or parking spots (G28/G30) are stored as offsets relative to the homing switches and are persistent (Untill changed)
So you can power OFF, power back ON and run $H and same work zero is maintained.

In Fusion under CAM/Setup/Stock have you edited the stock offset that Fusion default to?
(Top offset = 1mm bu default)

i have it set to Stock offset mode = No Additional Stock

In UGS, what is your workflow to establish work zero?

Where is your drawing zero in relation to the x carve? In many cases, I make the home switch location the zero on my drawing and that makes everything simpler. In the event of a power failure or lost steps ( like when I run into a clamp for example), I can just rehome and start again. This is just my way of dealing with some of the X controller quirks. Also I have just kept the stable older version of UGS and it is simpler and works. It sounds like you just need to make the Fusion 360 settings a bit different than what it is now. I don’t use F360, so I can’t speak to that.

my workflow currently with UGS (this is my first cut using it) is to connect, home the machine, and manually move z axis to the work piece. I realize that i didnt disconnect and reconnect UGS after all that and that could have caused my issue. ive played with a few different steps, but still working it out

this makes sense. then if something goes wrong, i can come back. ill do some more research and see if I can mess around and get it right.

thank you guys for your help so far.

Please don’t get in that habit! It’s not a typical, or efficient, workflow.

My workflow is the same as @HaldorLonningdal’s, but I use CNCjs.

Use the jog commands to set your Z if you’re not probing.

I have little experience in the CNC scene, and I dont find UGS that cool vs Easel (for some reason, sometimes my machine stop working properly until a cold reset if I use UGS… work coordinates get all screwed or something like that).

If you create an sketch in Fusion 360, project the geometry, and then save that sketch as dxf, it will import perfecly into easel and you do no have to deal with UGS.

If you have homed the machine and clicked Reset Zero that position is persistent.
What the coordinates (both machine and work coords…) read do not affect this at all.

Test it:

  • power ON, home ($H), jog to an arbitrary position, click Reset Zero and power OFF.
  • Power ON again, home ($H), and in UGS click Return to zero
    What happens?

By moving manually, do you mean you Jog using the jog commands or pushing the gantry by hand?

I kinda like Easel myself but tend to use UGS (v1.0.9) when I export from Fusion, simply because the UI and reliability of UGS suit me better. Easel have all these pesky “Confirm this…that” steps that need to be done each carve :wink:

I have not tested the DXF export - Easel import of DXF yet but from what I gather is that its working good.

Something in OP’s workflow is messing up his result, I’d like to know why :slight_smile:

Lol that is true, but “tab, enter” without actually reading flows fast :stuck_out_tongue:


Good, ruling out one possible scenario :slight_smile:
Ruling out another, do a 100mm jog = a 100mm travel?

I did the calibration, and a 1mm jog on x was 0.86mm
a 1mm jog on y was 0.99mm
a 1mm jog on z was 1.6mm

I then entered the steps that were estimated, and clicked update for each (not y)

edit: to answer your question, I have not tested after making the above adjustments. i will do that shortly.

When you calibrate, always use the longest travel possible to minimize any backlash component in your system :slight_smile: Command/measure 300mm or 500mm or 700mm, the larger the better.