Fusion360 Crash

Well, just had my first major crash, Fusion360 did something REALLY weird. Program ran fine, tool change ran fine, all smooth and normal… right up until it went back to its “rest” position at the end of the program. At which point it drove my nice, pricey 1/8" Freud upspiral cutter slam-bang into the corner holding screw, and plowed a half-inch-deep gouge right across my project (my last good chunk of walnut, too). WTF? I’ve run quite a few programs with this exact setup before, and it’s always gone to it’s “safety height” home position high and left when it’s done. It’s like this time it decided to go somewhere totally different. That doesn’t represent a zero in any coordinate system in my machine, as far as I know.

I really, really hate unreliable software. Works 9 out of 10 times, then does this? WTF? Now I’ve got a broken mill, and the last chunk of my walnut is scrapped. I’m very impressed with Autodesk right now. :rage:

If you post your Gcode file for that project I will run it through Gwizard Editor and see what the back plot looks like. Or if you like you can Email me the Gcode file at dmsohl at tds dot net.

Hope I can help

Dave 1910 PDT

I’ve uploaded it here. I suspect the problem is somewhere in the end homing… This is where I’m REALLY tempted to spend the cash on that.


Cut same straight line on other bottom corner, no one can tell what it is. Luckily it’s on exact corner with 45 degree angle.

I just posted that program again, splitting it into a pair of separate programs, one for the .250 primary cutter, and one for the .125 detail cutter, then ran them one after the other. No trouble at all, part came out great. So it has to be in the tool change, somewhere?

The back plot in Gwizard Editor does not through any errors and the program ends after cutting that small pocket in the upper left hand corner of the 2nd square pocket from the left. From there the Z goes to safe height of z0.6 Here are the last 6 lines of the code

G0 Z0.6 (rapid to safe z)
G17 (X-Y plane selection)
M9 ( coolant OFF not needed could be deleted)
G28 G91 X0 Y0 (G28= return to home G91= incrememtal programming XYZ (type B and C systems))
M30 ( end program with rewind)
M5 (spindle off)

I think you are right that it is that last return to home that did something strange to cause the spindle to cut that grove in the piece.

Take a straight edge and draw a line from where the program lifts to safe z to where it ended and I’ll bet they are in line. Also look at the groove and see if it has a tapered bottom. I also bet it does. return home moves all three axis at the same time.

Hope this helps


1 Like

Yes, the behaviour was PRECISELY what it would be when it was returning to home normally, which is why I wasn’t able to flatten the E-stop quickly enough. I didn’t realize anything was WRONG until it bit the material. The move was a precise, linear motion in three axies, rapid, from the last raise to the “home” position, which was the same X-Y as it should be. Just a half-inch or so below the surface. No idea WHY it decided that the Z moved! It’s almost like it decided to go to X0Y0Z-.6 instead of X0Y0Z.6

If you remember on this forum, some gentleman was trying to explain difference between Machine zero and work zero, related with safe Z rise. Looks like after you change tool, G-code tried to go back to machine zero instead of work zero.
I’m not very much in love with Fusion360, that’s why I didn’t pay much attention. You may want to search and watch the video if you already didn’t.

It went from where it went to safe Z to X0 Y0 Z0 If on the tool change you did not get the new tool at the exact same length to the first tool then Z0 would be deeper if the tool was longer or shallower if the tool was shorter. Check the depth of the holes and the corners to see if they are at the correct depth.


Something like that, I broke couple of bits than quit. I think best exercise is making partial tool path instead of tool change.

Alan is probable right that return home goes to machine 0,0,0 and not G54 0,0,0


The second bit was shorter, and the areas it was supposed to cut are cut to the correct depths, so all was working well there, anyway. I think I will be just sticking with splitting the programs, I can’t afford to hose material and bits!

The other thing you can do is edit the Gcode and remove the return home. Then the machine will just go to safe Z and stop.


1 Like

That’s probably the best bet, I think. I can just modify the post to do that.

Splitting it into two ops made it run just fine.

1 Like

Looking sooo good. Great work Dan.

1 Like

Thanks, Alan! I like how this one came out myself. It’s a request for a fellow, a holder for ink bottles and a pen. :smile:

Just chiming in to say “great work!” as well. That’s mighty fine stuff, and I can’t imagine the recipient being anything but ecstatic when they see it. :smile:

1 Like

Fargin’ thing did it again, on a different piece! It’s definitely not related to the M6 tool change op, I ran this one as two programs in CP. I think it might be the M28. This time the cutter ended up at X0 Y0 Z-.350 according to CP. I have NO idea why it would deliberately home to a point that has a negative Z-value! The only thing I can think of is that when I’m jogging in CP, somehow it’s getting whatever homing point it has selected messed up. I’ve taken some steps to stop this whole mess - I’m soft-resetting the entire thing between tools now, and I’m going through my code to manually replace the M28s with “M90 G0 X0 Y0 Z0.5” So far, that has yielded flawless results. Kind of awkward, I wish the post files for Fusion were easier to modify so I could make the necessary changes in the post instead of manually for each posted file, but it’s working!

For reference, I’m using the stock GRBL post, and manually adding a Z-move at the beginning so that it raises the cutter, THEN moves it to starting location.

This is the successful run, after re-posting and manually editing the code. The lettering was done with V-Carve, the rest with Fusion 360, and run as two separate programs. I have something not QUITE right with the V-carving, it’s leaving way too much crud in the bottom of the letters, but that’s something I’ve messed up creating the tool, I think.

1 Like

@DanBrown, those are turning out great. Keep up the good work. I’ve been watching a lot of Fusion tutorials over the past week or so, and working on a design that I’m looking to carve soon I hope, so I’m definitely watching this thread and your notes, in the event that I experience something similar. Thanks for sharing your experiences here.