Gcode carve failure with anomalous reset but not every carve affected

My x-carve 1000 works fine with some imported gcode files but with other files it proceeds part way through a carve and then resets to the home position. The work area in each case is no more than 100mm x 100 mm. Is there a specific G command that I should look for in the Gcode or is there anything else I should look at. I try a carve and it fails at less than 1% progress so I import a different Gcode file and it carves to completion. Vectric Vcarve pro is used to produce the Gcode files. Any help would be appreciated.

I posted having read through all of the previous posts to no avail. I have now fixed the problem! The root cause was a power surge that had damaged the laptop that I was using to interface with the X-Carve. I followed a post which suggested driving the X-Carve direct with gcode thus by-passing easel. The nature of the fault now changed, the X-Carve worked for nearly 45 minutes before the carve failed so clearly the fault lay elsewhere. The only change since I first used the X-Carve was thus a known period of power supply voltage instability which appears to have rendered the old laptop unreliable. A thorough cleaning of the laptop cooling did not offer any improvement so I took the plunge and bought new. A new laptop cured the issue.

As ever, an intermittent fault is always the hardest to cure.

Windows. Mac? Did you turn USB to " not turn off"

Windows 10, windows set to never sleep, usb ports permanently on. The original laptop would process 4% of a 985 Kb file, the same gcode file sent through ugs would proceed to 48% before failing. The problem did not exist prior to power instability, a large file which needed 4.5 hours to process and carve was not a problem. After the power issue whilst searching for answers I tried the 4.5 hour cut again ( no tool in spindle ) and it now failed at around 3.5% from start.
That is why I opted to change my laptop. The original laptop was an asus V1 it started off on windows ME, was updated to Vista the updated to Win 7, Win 8 and finally Win 10. At the time of my problem I didn’t think it owed me anything so I got a new Dell and am very happy with my X-Carve, Easel and life in general. Hope that this tale may help someone else in the future.

I just ran into the same problem. I ran the same g code twice with Easel. The first time it ran 11% then back to home. The second attempt it ran 13% and back to home. I then ran the same g code with the universal g code sender program and it work without missing a beat. This machine is running in my lab so power is monitored. What I was able to figure out, in my case, was my internet band width was being use by multiple devices simultaneously. I think what I was experiencing was a pause in transmission and the x-controller saw this as the end of the program and returned to home. If we could get some feedback from the engineers, I bet we would find the x controller can time out if it does not receive an instruction in a fixed amount of time. Just my thoughts. If you have the problem again, go offline with the universal g code sender and see if the problem goes away.