Getting Started

Frustrated! Checked and rechecked to ensure all wires are connected properly and in the right location. I get one blue light, but the computer fails to recognize the Arduino (saw it, in devices and printers, for a brief moment once). Is it possible to have a bad board, but still get one blue light?

The blue LED is just an indication that the 24 volt power supply is turned on.

If your wiring is correct the most likely problem is that you don’t have the gShield plugged into the Arduino correctly.

It’s very easy to plug it in without the mating connectors lined up properly. Using a flash light and some care you can look under the gShield to see if the connectors are plugged in correctly. If you can’t see it , then you can take the electronics out of the case, make sure you get the boards lined up right and test it that way to see if the alignment is the problem.

If you have it right, with the USB cable plugged in to power the Arduino and the gShield logics, and the 24 volt power supply on then you should see the blue LED and three green LEDs lit up.

Some people have had issues with the USB connection. Many got relief by using a powered hub for the Arduino.

Thank you for the help. All was good (after several more checks and rechecks). Still no green lights. Inventables support has sent an email and hopefully can come up with an answer. Thank you, again.

Hi… looking for some help to get my xcarve started. i got both blue and green lights on solid, the xcarve appears as an unknown device under devices and printers folder… and when connecting to the usb port there is some small initial jerking motion but that is it… how should i go about identifying the port where the xcarve is connected and most important how do i go about getting it identified by my computer. i am running windows 10 on my unit.
Your advice and direction will be greatly appreciated

Have you gone through the initial setup instructions in Easel? That’s the fastest way to get your X-carve setup.

During that process you are instructed how to load the Arduino drivers using the Arduino IDE. Have you done that?

Once you get the drivers loaded and can see the Arduino on a COM port you need to make sure that, that COM port is set to 115200 for the baud rate.

Hi Larry
Thanks for the prompt reply. I was going through the set up process when encounter the issue I described. I did have the Arduino IDE drivers already installed in my computer however the computer did not recognize the device connected.
Shortly after posting I got to review other users posts and noticed that only 2 of the 3 green lights in my unit were actually solid green and blinking when jogging so I did removed the gshield and re-stacked again, then the device was recognized and all green lights were on… however there was still jerking to no movement on the Y axis, therefore I reduced tension on both Y belts and the Y axis start moving consistently but still with some jerking when compared to the X and Z axis.
I did make sure that the Baud rate was set at 115200 as indicated.
Is there something I am missing to do/check and ensure smooth displacement on the Y axis?
Sorry if this seem all is obvious to you but I am a real newbie here as you can tell.

We were all neebies at one time (I’m still learning).

Try to increase the current limit on the Y axis. The potentiometers on the gShield do this. If you have NEMA 23 stepper motors set the pot for the Y axis at about 11:00 o’clock.

Hi Larry, just for clarity, shoudl I use the front of the power unit as my base reference when looking for the 11:00 position?

Good point. Take a look at this photo. If you are good with a voltmeter you can use the test points indicated here to set the current limit precisely, but if you set the pots as shown here that’s a good starting point for the NEMA 23s.

Maybe your expectations are a little high considering that this product is a kit and that the turn-key units that provide the same functionality cost from $3000 up.

It’s certainly not a plug-and-play product, but for the price point it’s hard to beat.

Everything that is this flexible has a learning curve and once you get it set up and working then most of the frustrations will fade into the past.

Not quite sure what happened last night, but after I reinstalled the gShield to the Arduino…still nothing. Followed a little advice from another user…added a Terminal Block in the place of the Right Angle Header Connector. This allowed for all motor wires to attach directly as opposed to using the Header Connector Pins. Rebooted everything and low and behold…success.
Thank you so much for the help you provided!

Apologies…not motor wires, Limit Switch wires.

Your right. Dont post while extremely frustrated. Its like drunk texting… just a bad idea. Comment withdrawn.

Hi Larry, I made the change recommended and it seem to work… I also found that I have tight up a little too much the eccentric nuts, so loosen them up also helped. Now I have another issue… the spindle do not turns off… I found that someone else had the same issue and it was resolved so I am following that thread now…
One other thing, I am puzzled by the green led lights (gshield) as they sometimes remain solid green and blink when the axis moves but some other times they turn off… Y axis light tend to remain off until the axis moves, X and Y shift from solid-blink to off -blink when the axis moves on either direction, is this to be expected with normal operation?

Yes, it’s normal for the green LEDs to be on, off, blinking during normal operation of the machine.


Different guy/ same problem. First shot. 1 blue and 3 green lights. COM identifies Arduino and its set to 115200. I’m stuck in Easel where it says connect USB and turn the machine on and Cancel is my only option.

If you are running on a Windows machine, bring up the device manager and drop down the “ports” entry to see the COM port listings and specifically the entry for the Arduino. Leave that window up so that you can watch it.

Then go into Easel and see if the port is still there when you get to the point where Easel hangs.

1 Like