Goko v0.3.4 - Support of Grbl 1.1

Hello,

Just a quick message to inform you that Goko 0.3.4 was released, and includes a full set of features for Grbl 1.1
It allows to control your Grbl based CNC and stream GCode to it.

Changelog is available here : http://docs.goko.fr/master/changelog.html#version-0-3-4

Latest binaries can be downloaded at http://goko.fr/

Have fun, and feel free to post feedbacks :slight_smile:

Psyko

1 Like

http://x.ite.lt/HmddwbCymR.png
1495999809846.log (207.5 KB)

Yeah, well, what does the log file say ?
It’s on Mac ? Couldn’t test it because I cannot get a descent test environment for Mac…

If you’re not sure what to look for in the log file, please send the file at contact@goko.fr

Log file attached

Oops, my bad.

After a quick look, it looks like you’re using Java 1.6.0_65, when Goko requires Java 1.7 at least. Try upgrading to Java 1.7 and it should solve the issue.

Doesn’t run for me either on macOS.

I’m running Java 1.8… java full version “1.8.0_11-b12”

Looks like either it’s not finding some class it needs to activate:

java.lang.NoClassDefFoundError: org/goko/core/common/service/IGokoService

or a permissions error trying to write some metadata:

java.lang.IllegalStateException: The platform metadata area could not be written: /private/var/folders/80/65jdrsjx4qv_y7d0vd5sg06r0000gn/T/AppTranslocation/4F1D5AA6-ADFE-4D3D-8276-E8019115ABA3/d/Goko.app/Contents/MacOS/workspace/.metadata. By default the platform writes its content
under the current working directory when the platform is launched. Use the -data parameter to
specify a different content area for the platform.

I’m willing to do some testing for you if you like.

Hi @Peter_Jakab,

Thanks for the help, it’s greatly appreciated since I do not have a OSX test environment.
Can you please send the complete log file ? I’m not sure you’ll find it because of the permission error.
There are actually 2 files :

  • 1 in the log folder,
  • 1 in the workspace/metadata/.log file

Thanks

I found 3 log files under this directory:
/Users/jakab/.eclipse/2090292858_macosx_cocoa_x86_64/configuration

I’ll try to attach a zip file here. Two appear to be backup files, so they may have rolled over. I did not find any directory related to your app in any of my workspace folders. If you have fully a qualified path for me to look in let me know.

Thanks, lets try and get this figured out.

Logs.zip (38.6 KB)

Thanks @Peter_Jakab

It looks like the permission error is the root cause of the issue.
I’m not familiar with OSX, but is there any chance you can run it as admin or root user ? It’s not the clean way to fix the issue, but at least we can make sure it solves the issue.
Or try and edit Goko.ini and add the following (right before -equinox.ds.debug=true):
-data PATH_TO_WRITE_ALLOWED_FOLDER

I’m not sure what PATH_TO_WRITE_ALLOWED_FOLDER should be, but definitely somewhere where you have write permissions.

Thanks for taking time to help :slight_smile:

Hi there. Some good news…

I had Goko on my downloads folder, and that’s where I had try to run it and got the error message.

I then, just now, moved the app to my Applications folder and tried to run it again and it worked. I made no other changes, not even a reboot. So, I’m not sure why it worked this time, perhaps running from the Applications folder changes where Eclipse is trying to write his files to. Don’t know.

This is as far as I can go this week as I’m not where the machine is. I will be back home on the weekend and will try to actually use it and connect to my X-Carve, see what happens then.

Feel free to contact me if you want any more testing, or if you want me to pretest before you release a new version.

Glad to read that :slight_smile:
It’s probably because it tries to write some properties on the workspace area of the application at startup. Without proper permissions, the startup sequence fails.

Thank you for the help in testing :slight_smile: I will definitely contact you for new versions, especially the Mac part.

Yup, no problem.

Thank you for all your work.

If need more mac testers count me :wink:

1 Like

@NerijusZut Thanks, will do :slight_smile: