Grbl cnc z limits not working

I have grbl cnc and my z axis limit not working and homing fail x and y limit working perfectly
$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=1 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=1 (homing dir invert mask:00000001)
$24=50.000 (homing feed, mm/min)
$25=160 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=3 (homing pull-off, mm)
$100=160 (x, step/mm)
$101=160 (y, step/mm)
$102=24 (z, step/mm)
$110=150 (x max rate, mm/min)
$111=150 (y max rate, mm/min)
$112=24 (z max rate, mm/min)
$120=50.000 (x accel, mm/sec^2)
$121=50.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=225.000 (x max travel, mm)
$131=125.000 (y max travel, mm)
$132=170.000 (z max travel, mm)

There were some pin changes that affect the Z homing switch.

Read through this thread completely to determine the best solution for your situation.

Swap Z-limit from Pin11 to Pin12 instead if you are running GRBL v0.9 or higher.

1 Like

there is a problem…when i pressed the limit switch the motor stopped working but its not accepting the next feed to move in another direction. in short , its actually blocking the whole machine . what to do ?

You need to clear the alarm state caused by the limit switch. In GRBL you can do that by sending a “$X” command.

Are you referring to the pins on the controller card? I’ve double checked all connections, switch, DIP settings, potentiometer, grounding, etc. The only thing I can think of at this point is code. Switch activates but doesn’t tell the motor to stop. Waiting to enjoy my new $3000 toy so I can get business rolling.

Hi there Mitchell, is this an Older CNC, or a new one. Is this a brand new Xcarve (Post Nov 2021 model) ?

I ask because if it is the new X-Carve and the issue is the Z limit switch and it’s failing to home properly, this is a known issue based on the limit switch selected and the position of the mounting screws making it possible to end up with a physical stop (linear rails to run out of travel) before the limit switch is depressed enough to activate. This is the solution:

It’s the newer post Nov-21 X-Carve kit I just finished assembling. Using my laptop I’ve been able to run partly through the setups and all the axis movements are good. Moving into homing though, I’m hitting issues. When the Z-axis is moving up to the limitter switch, even if I manual engage the switch and hear it click, the motor will not stop. It’s like the controller doesn’t see the switch or it just doesn’t send a stop command to the motor. I’ve tried bending the switch arm down so the switch engages before hitting stop. I’ve tried changing out the switch. I’ve check the wiring, including ribbon cable inside the controller, but still, nada. I just have to continually power off to keep from burning the motor up.

1 Like

You could open machine inspector in easel press ctrl+shift+D then there are indicator dots that turn green when the limit is pressed you can test them all by hand and verify there is an issue with them. Either the controller, cabling, or the switch itself might be bad… if their bad youd want to submit a help ticket or make a phone call to tech support

BINGO ! OMG. Z showed X dot lighting up, and vise versa. Switched the two connection wires, which somehow were flipped, and shazaam, homing completed. Now just on to setting Z start. Checked the grounding of the puck and all is good there. Just have to get familiar with how to set what it knows as drop bottom with a new bit, and align the material.

1 Like