GRBL configuration with ACME rod

Can someone please post a listing of their Grbl configuration setting using the ACME rod. I am not sure what the $2 setting for Z axis movement per step should be.

Thanks!

@AllenMassey

188.95 steps/mm

BTW: I have this spreadsheet that you can play with. It should be read only, but you can save a copy and edit it.

@BartDring: Your spreadsheet shows 40 steps/rev but I assume this is the X & Y steps/mm setting. Examples I’ve seen for a final setting have been 40.20 steps/mm. What accounts for the difference?

Where do you see that number? I think someone did the calculation in inches once, then poorly converted to metric.

Thanks Bart, so it looks like $2 = 2.117 Is that correct for the ACME rod?

No you want $102=188.95. 2.117 is the ACME lead screw pitch. You need the other factors. I don’t know where $2 comes from. That is a step port invert mask.

comes from line 5 in the shapeoko 2 wiki for settings with universal gcode sender

line is
$2 = 320.000 (z, step/mm)

The first place I saw that figure was on the Shapeoko builds docs:
http://docs.shapeoko.com/software.html

OK, thanks.

That info is pretty old and not correct.

The $2 is pre 0.9 grbl. $102 is what you want for Z. See this wiki.

40steps/mm is correct for X and Y with 8.

grbl will work in inches with gcode, but the settings are entered in metric, so all calculations should be done in metric.

1 Like

Thanks again, what other variables do I need to change to reflect that I now have the ACME rod? Sound like I probably need to download the latest Grbl version also, so I may need to reload all the configuration options. Are they all listed somewhere?

@AllenMassey,

If you go to http://easel.inventables.com/setup, it will guide you through configuring the grbl settings for your machine.

1 Like

Does anyone have any idea why my grbl controller would have 188.976 as the z steps/mm? I have an ACME rod and set it up through the Easel wizard.

Have you tried to set it up again after noticing that the Z steps were wrong? I had originally set my ACME with easel also and a few days later noticed that it had switched! might want to try to re-calibrate in easel.

It looks like A22 in the spread sheet is hard coded to 200 — shouldn’t it be A21 * A22?