Grbl laser

Does anyone know if there is a way to switch from mm to inches in the program. I have been all over it and can not find anything. Thanks

GRBL has a setting that you can use to have Grbl report co-ordinates in inches to the calling program. Use $13=1 to have grbl use inches.

You may have to change your sending program also.

1 Like

Sounds complicated so maybe i better just use my conversion chart. Thanks

@WayneHall Do you mean for the program called “LaserGrbl”. I don’t know, but you and Larry might be talking about slightly different things.

Yes that would be the program. Thanks

Maybe it can not be changed because i have not found anything to change it.

It’s happened before. No reason to think it won’t happen again.

1 Like

No big deal. Thanks

Ok, the version I tested ( I think it was LaserGrbl 2.8.xx ) everything seems to be in metric units, except the digital readout in the upper right hand corner. That readout follows the grbl $13 parameter setting.

$13=0 metric
$13=1 imperial

Not sure that would do any good, but that’s what it did for me.


I will give it a try. Thanks Larry