GRBL problems...?!?!

OK, im not sure what to search for or I would just look this up, but I’m having a weird issue, I opened up machine inspector and told x to go “x20” instead it goes about to about x200, so then I send x-20 it moves about -20 then locks down and won’t accept any more commands , after restarting the X controller I notice its doing this every time on all of the axis, WTF?!?! is going on here I had this machine dialed in, and all of my steppers calibrated 2 days ago down to the MM!?!?!

Post your $$ grbl output here.

$132=100.000 (z max travel, mm)
$131=790.000 (y max travel, mm)
$130=790.000 (x max travel, mm)
$122=50.000 (z accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$120=500.000 (x accel, mm/sec^2)
$112=500.000 (z max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$110=8000.000 (x max rate, mm/min)
$102=188.976 (z, step/mm)
$101=39.837 (y, step/mm)
$100=39.837 (x, step/mm)
$31=0. (rpm min)
$30=1. (rpm max)
$27=1.000 (homing pull-off, mm)
$26=250 (homing debounce, msec)
$25=750.000 (homing seek, mm/min)
$24=25.000 (homing feed, mm/min)
$23=3 (homing dir invert mask:00000011)
$22=1 (homing cycle, bool)
$21=0 (hard limits, bool)
$20=0 (soft limits, bool)
$13=0 (report inches, bool)
$12=0.002 (arc tolerance, mm)
$11=0.020 (junction deviation, mm)
$10=115 (status report mask:01110011)
$6=0 (probe pin invert, bool)
$5=0 (limit pins invert, bool)
$4=0 (step enable invert, bool)
$3=4 (dir port invert mask:00000100)
$2=0 (step port invert mask:00000000)
$1=255 (step idle delay, msec)
$0=10 (step pulse, usec)

That looks good. I don’t think grbl is the problem. Are you working in inches or mm?

It just depends on the project but for now I’m just trying to use the console to send a command I just re flashed grill gonna see if it made a difference

You might also try a different program to send the commands. It could be an Easel. issue.

yea i tried UGS as well , so the re flash didn’t make any difference which is strange its even retaining all of my settings , do i need to “reformat” the controller before flashing?

when you go into machine inspector does it show probe status as green even though its not plugged in ?

Grbl does retain the parameter settings even when you re-flash the firmware unless you change to a version that has a different EEPROM layout.

You can do a ? command to get the status of the homing switches and the probe pin, but UGCS will not send a ? command. You would have to use something like the Arduino IDE serial monitor or PicSender. Easel might do it, I don’t use Easel so I don’t know if it works there or not.

You already have the status report parameter set up properly to get the info.

1 Like

yeah I’m totally baffled as to whats going on here… in UGS or Easel I can send a command like “X20” it goes really far then I type “X-20” it moves back which seems like the correct length but then it just freezes won’t do anything I have to go into UGS and unlock the machine…

Try starting up your machine from a powered down state, then do your normal procedure to set up for a job. Close the program you used to do this.

Bring up the serial monitor in the Arduino IDE (make sure you have the correct board type and COM port set up under the Tools menu).

Make sure that the serial monitor is set for 115200 baud and the “end of line” is changed to “Newline”.

Enter $C (should turn off machine movement but will still execute the commands)

Enter the following commands and save the output for me to look at: ? then $# then $G

Enter G91 X20 (should “move” the X axis 20 (mm or inch) from the current position without machine motion).

Enter ? $# $G (save the information)

Enter G91 X-20

Enter ? $# $G (save the information)

Post the results here.

1 Like

Ok so last night I tried using UGS and when I jog the machine I notice it sends “g0 X1” so I manually typed g0 x20 and it moved like it should in in reverse with g0 x-20… then I noticed after doing that my problem has gone away entirely , like I can input x20 and it’s moving correctly , even in easel. Why did using the g0 command fix the issues I was having???

I usually don’t, I was trying to check my calibration and that it is still on point, but i noticed when i hit the jog button in UGS it was adding G0 to the front of the code…what does the "g0"command do? why did it fix my weird issues.

Some of the G-code commands are persistent until you enter another G-code command that changes it. So when you enter the following code

G0 X1
X35 Y20

The G0 command is persistent. The following code is an exact equivalent of the code above:

G0 X1
G0 X20
G0 X35 Y20

So, then

G0 X1
G1 X0 Y0
X20 Y15
G0 X0 Y0

is the same as

G0 X1
G0 X15
G0 Y20
G1 X0 Y0
G1 X20 Y15
G0 X0 Y0

There are several G-code commands that fall into this category.

Ok that makes sense, what both of you are saying , I’m trying to learn the g-code I actually know a few programming languages , it’s part of my profession , I’m just have a hard times with it because it’s really basic and I’m used to more complex code . It’s a lot more math than logic reasoning… if that makes sense .