GRBL settings for cnc4newbie HSNC4848RP

I purchased a cnc4newbie HSNC4848RP machine and trying to use my xcontroller. I was surprised to see easel had my machine listed under 3rd party machines. Ive been able to get it operational but the GRBL settings seem to be off. I tried running a simple square cut but the machine isnt starting from router position and seems to be traveling greater then the size values ive input.

Any and all help/advice would be appreciated. The HSNC4848RP is the rack and pinion machine from cnc4newbie.


you would wan to use the grbl settings you cnc manufacturer provides and then do the manual calibration to verify those default settings are accurate enough.

The calibration process is identical for your cnc as the X-Carve: How to Calibrate the XCarve: Stepper Calibration - YouTube

1 Like

So i added the GRBL settings for my machine but for the life if me i cant get easle to start my project from xy-zero. I havent added a z probe yet. Could this have something to do with the machine no starting from xy- zero?

it should still allow you to select manual Z and place the bit on the front left corner at the top surface of the workpiece and it should allow you to begin the carve from there.
If it doesn’t then I would jump back into that machine inspector page to see if there are any alarms showing.

No alarms showing. It still wont start a project from the current position. Im also placing my project cent on the xy-zero.

The new center zeroing method

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.