GRBL Update note registering position

Has anyone come across the update to GRBL 1.1F and the position not registering in Gcode Sender ???
I have checked the $10 figure, and tried the two that I am aware of. (3 or 115)
If there is a fix, I would be muchly appreciative.
Thanks in advance.

(Checked the java is upto date and drivers are all updated etc etc etc)

Are you homing?

no … Just general positioning. It doesn’t seem to register any movement at all.
It will still run the code and return home if you cancel the job, just the position never changes from 0, 0, 0.
Work or Machine.
I have been having issues with the machine for a while now, and am really trying everything I can think of to get it back up and working again. I have replaced the gShield, the Arduino, the axis motors and the entire wiring loom, and still can’t it to work effectively. I must admit, I am new to the programming the setup, the machining and gCode side of things is fairly easy for me having used big 5 axis machines, but this unit is doing my head in trying to get it sorted. hahaha.
I found that using the gCode Sender might have some issues, but can’t seem to find a fix for. As it runs the CMD in the background, I checked it to see if there were any errors, and it came up with this each time…

Got any ideas ???

1 Like

Try a different version of UGS?

The user interface to grbl changed with version 1.1f. You need to make sure that the G-code sender that you are using has been updated to support version 1.1f.

The correct setting for $10 in version 1.1f is 1 ($10=1) to get status reports. Status reporting has been changed so that it doesn’t report all items with each request, but has an internal mechanism to report things that have been changed since the last status request. The various status reporting times can be changed with compile time parameters.

[Edit] Should have said the default is $10=1 that gets you Machine Position and other settings. $10=0 gets you Work Position and other settings.


Whoa dude. Explain. U just blew my mind. @LarryM

1 Like

What version is current of the gCode Sender ???
I have v1.0.9 , and i thought it was the latest version.
If that doesn’t work, any other suggestions ?
Did I install something wrong for it to have the errors in the CMD section ?

UGCS version 1.0.9 is the latest stable release, but does not support grbl version 1.1f.

To use 1.1f with UGCS you need to get the nightly build.

PicSender supports 1.1f (latest version is 2.7.5)

I’m not sure about Easel.


There are a lot of changes. Explain what?

1 Like

Awesome, I just did a bit of research and found the Nightly Build, so I might give that a try …
Thanks heaps for the heads up. I am slowly learning what needs to happen to make this machine great again… Hahaha
It a constant middle finger having it sit there idle knowing it was working sweet only a week or so ago.

1 Like

What’s the settings options and what do they do?

configuration settings

Got it. I must have skipped it when I first read all the data stuff

Try platform ugs

JeremySimmons, I am having a heck of time. I have read thru the config settings and successfully changed $10=1. I still don’t get the machine position to show up. running ugs 1.09 and grbl 1.1. Any advice from you or anyone would be greatly appreciated. Thanks in advance, Bill.

UGCS 1.0.9 does not support grbl 1.1f

For grbl 1.1f use the UGCS nightly build.

$10 = 1 means Enable MPos:. Disable WPos:.

Position type may be specified to show either machine position (MPos:) or work position (WPos:), but no longer both at the same time.
Enabling work position is useful in certain scenarios when Grbl is being directly interacted with through a serial terminal, but machine position reporting should be used by default.

I believe you want to set it back to $10 = 0, which is Disable: MPos Enable: WPos

can you run Status Report Query ?, and reply with the results?

The reason I state the above is that without a response in the report query command that starts with WPos, there’s no data to parse in getStatusFromStatusString

Thanks for the info!

Keep posted on your ‘status’. Happy to help troubleshoot.

Can you provide the output of the ? command?