GShield Green & Blue lights stay on, but no movement!

I just got my X-Carve recently. I have done a couple test carves. But I went to do a job this morning, and had a bunch of garbage text on my UGCS screen! I restarted UGCS and my GShield and Arduino, but now no movement!

I noticed when I turn it on the blue and green lights on my GShield stay lit. The green lights are suppose to go out, and only light when steppers are in use, right?

I tested the Arduino Uno, and it checks out fine. I can move the X,Y and Z and get lights on the GShield when off.

Bad GShield? Any ideas?


The blue LED just indicates the presence of 24 volts. The three green LEDs are in parallel with one of the windings in each motor (axis). Normally the green LEDs are lit when you first bring up the Arduino and gShield. They turn on and off based on the polarity of the voltage on the motor winding. It is normal for them to be on, off, or blinking, it just depends on the polarity of the voltage at any given moment.

First thing I would try is to turn everything off. Bring your computer up first with the Arduino USB unplugged. Plug in the Arduino USB cable and then turn on the 24 volt supply.

See if that corrects the problem, if not post your new results.

only light when steppers are in use,

The steppers are always in use unless you change a grbl setting. Even when the machine is not moving the gShield still provides current to the steppers to prevent them from moving.

I had this exact same problem when i first set up my unit. I did as Larry stated and brought Easel up last and then everything worked as expected.

I booted my computer, then plugged in the Arduino, then turned on the power.

The X.Y. and Z lights came on immediately on the GShield. And no control. The commands leave UGCS, but no response back, (OK).

If I unplug the USB to the Arduino, the green lights go off on the GShield. As soon as I plug the USB back into the computer, all 3 green lights come back on. If I leave the USB unplugged, and the 24v power off, and move any of the axis, I get the green light corresponding to that axis on the GShield.

I shut everything down and unplugged the GShield from the Arduino then tested the Arduino and it checks out in everything.
I did however find that I was not able to reload GRBL on the Arduino!

I have not used the machine very much at all, but when I did, it functioned fine.

I’m not sure what you mean by “the Arduino checks out in everything”, but you can’t re-flash it.

Just on first blush, it appears that nothing is out of the ordinary except you can’t talk to the Arduino.

Try a different USB cable and/or different USB port on your computer.

I used a ‘Blink Sketch’ to fire the LEDs on the Arduino. And I had no problems doing that. You can change the rate of blink of the LED by changing code.

And if the Arduino was bad, would I get the responses I get in UGCS from sending code to the GShield?

That’s strange. You could flash blink into the Arduino, but not grbl?

Both issues, not flashing and UGCS issuing commands but not getting an Ok, could be communications failure which could be anything between your computer and the Arduino. USB port on the computer, bad or intermittent USB cable, bad USB hub, bad Arduino.

I tried a different USB cable, in a different USB port got same results.

Wouldn’t you think the GShield would be the culprit in the communication issue? The Arduino relays it, it doesn’t get the response back?
The Arduino not taking the GRBL troubles me, and it may be bad also. But the fact that I can do everything else with the Arduino, save the GRBL.

And why would those pesky lights stay on, if it were the Arduino, any ideas?

I thank you so much for responding.

Almost everything happens in the Arduino. The gShield is a slave device and only does what the Arduino tells it to do, when things are working right. The gShield is not involved with the PC communications, that is all in the Arduino.

At this point, I wouldn’t worry about the green LEDs.

The major issue now is the failure to load in grbl. Are you doing this with the gShield attached? Try flashing the Arduino with grbl without the gShield attached.

If you can flash “blink” but not grbl then that points to a malfunction in the Arduino. It may be a memory problem that “blink” is not large enough to hit the problem, but when you try to load grbl it does hit the problem. Could be anything.

I would say if you can load “blink” reliably time after time (without the gShield attached) but you can’t load grbl then it’s time for a new Arduino.

This assumes that at some point you were able to load grbl, but now you can’t.

Yup, I tried to clear the memory on the Arduino, and it compiles the sketch but stalls while uploading it! I think my Arduino is defunked!

And I haven’t even used this very much! :frowning:

Call Inventables.

1 Like

Called Inventables this afternoon, Jeffery was great and expedited a GShield and Arduino out right away!

That was an awesome experience with them, never had a company work with me so quickly and no nonsense!

Hopefully all will be back on track next week!


Well I am back up and running! A big thank you to Inventables for the quick response! I contacted them late Friday, and Monday I received a new GShield and Arduino…and BOOM!

Everything is back up and running!

Larry, thanks for troubleshooting with me.

1 Like