Inventables Community Forum

Hard limits triggered in UGS

Hi wondering if anyone had any ideas , I think it might be something simple that I have set up wrong , but I have done quite a few carves using Aspire 9.5 & UGS2.0 (nightly) with the X-carve 1000mm x-controller 1.1 grbls , The thing is I have been doing carves on materials 22 mm maximum not any problems (apart from a few mistakes by myself) , But I am getting a problem now when trying to carve 33mm thick stock ! Probed as usual etc , & all looks fine until I start the carve (I then get a message saying hard limits triggered) I have always homed it & nothing has changed from other carves apart from using the 33mm stock & using a 1/4 mm end mill , I thought it might be a problem with the G-code , so just sent a file with a simple line 1mm deep & I am getting the same thing , the probe distance is set to 14.9 & distance set at -78.7 could it be a problem with that ? soft limits or something else perhaps ?

Retract height taking you up to your Z limit?

It shouldn’t be …I kinda thought it might have been something like that . but with sending another file just with a simple 1mm line it has done the same thing ,I am fairly new to all this & am wondering if there is something in the way I have set up , as I am working offline at the workshop (no internet) & just working with ugs & aspire ? here is what I have got in UGS , Im not sure if I will have to change a Grbls setting :grimacing:
Don’t know if anyone can see something amiss here ? thanks for any help It’s greatly appreciated !! Capture ugs settings 2 (1)|273x500

& here is the simple square I sent & getting the same problem … Don’t know if there is an obvious problem here T1
G17
G21
G90
G0Z45.720
G0X0.000Y0.000
S12000M3
G0X449.263Y209.893Z5.080
G1Z-2.000F762.0
G1Y244.893F2540.0
G2X452.438Y248.068I3.175J0.000
G1X492.438
G2X495.613Y244.893I0.000J-3.175
G1Y209.893
G2X492.438Y206.718I-3.175J0.000
G1X452.438
G2X449.263Y209.893I0.000J3.175
G0Z5.080
M5
G0Z45.720
G0X0.000Y0.000
M2

You’re retracting to 45.72mm above your workpiece.
Do you have that much room?

Ah Neil you might just have hit the nail on the head :+1:t2: I have just noticed that aspire seems to have default HOME/START Z position of 45.720 ABOVE the material
image regardless of material thickness entered , I have been taking it for granted that my safe Z height would be the setting to watch & that the probe module & Homing in UGS would take care of the home /start position , I will go & try it now with a different setting entered ! :crossed_fingers: … Or thinking about it :thinking: would that not then invalidate the purpose of homing & probing ? or is that leading me down the path of the homing or limit switch debate :see_no_evil: … Or how would I then know what number to enter for aspire without homing & probing ? ,or is that just the distance AFTER homing & probing in UGS that the spindle would go to before & after the cut ? …**** I’ve just bamboozled myself again :grimacing: Acht no !!! is it the chicken or the Egg ? The G-code in aspire should overwrite homing in ugs ? Giving me the error ! Or if I entered a number in Aspire for start/homing position for G-code that was under the maximum Z limits for the X-carve should that work ?

That’s it, only based on your work position.
The idea with that value is that it is your clear everything height. If you don’t need to clear a tall clamp or something that’s of your workpiece, just set it to the same as your safe Z.
When you’re using really thick material, you have to keep that number lower.
Enabling soft limits would prevent the crash, but you’d still get an error.

Neil , Thanks for your help there !!! I took it down to a 10mm clearance today & off it went :+1:t2: got a 3d roughing cut finished no probs ! I was getting wee bit confused there & no doubt I will again , but thanks to yourself that’s another wee problem ironed out ! Big Thanks . Next problem is if I can get a cheap chinese 3mm ballnose down the 30mm to finish the Horses heed without snapping it :flushed: