Inventables Community Forum

Have I messed up my X Controller

Hi All, had a very frustrating day yesterday trying to understand what’s happened to my X Carve. Here’s what happened. I was doing some test carves and everything was working fine. I was using Universal GCode Sender and then it seemed to loose connection to the controller. In the end I switched off the PC and controller and tried to bring everything back online to connect.

The controller is powered on and I can see it listed under devices as X Controller. I can see in device manager that it is on COM3. In Universal GCode Sender it connects I can hear the steppers click, but thats about it, then it seems to click every 5 seconds or so. if I try to run a job or view firmware I get a message "GRBL has not finished booting. Equally If I try to use Easel It doesn’t think the machine is connected.

Things I have tried.
re-installing drivers
dismantling and ensuring all connections are good
Connecting directly to the board with a mini usb
Tried to update firmware with Arduino IDE (this failed to connect and upload)
Completely disconnected the X Controller to attach to another Windows 10 PC that had the Easel Drivers installed. and had the exact same result.

Would be grateful if anyone had any ideas that could help me trouble shoot the problem. Got a feeling this problem is really gonna improve my understanding of how everything works, up until now the XController has been a mysterious box of magic. :smile:


Try using Xloader to flash GRBL.

Inventables 1.0c HEX:
Inventables 1.1f HEX:

Thanks Justin, I’ll try this evening and report back

This is usually a baud rate mis-match. Do you have your baud rate set at 115200?

If it’s not baud rate then try re-loading the FTDI driver on your PC.

Hi Larry, I’m pretty certain that baud rate is 115200. will go back and check though. I’ll also completely uninstall the FTDI driver before re-installing.

Hi All, I tried to use Xloader and it just hangs forever. I also tried using Arduino IDE and am getting the message below.

I completely uninstalled the Easel drivers and reinstalled. Can anyone think of anything else to check? or a way to test the board? Because it happened whilst It was working, I’m wondering if vibration caused anything to come loose on the board.



USB Serial Port

Port Settings2.

Sketch uses 31646 bytes (98%) of program storage space. Maximum is 32256 bytes.
Global variables use 1646 bytes (80%) of dynamic memory, leaving 402 bytes for local variables. Maximum is 2048 bytes.
Low memory available, stability problems may occur.
C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.10.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avrdude -CC:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.10.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\Workshop\AppData\Local\Temp\arduino_build_722219/grblUpload.ino.hex:i

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:00:53
Copyright © 2000-2005 Brian Dean,
Copyright © 2007-2014 Joerg Wunsch

     System wide configuration file is "C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.10.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf"

     Using Port                    : COM3
     Using Programmer              : arduino
     Overriding Baud Rate          : 115200

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x82

Call Inventables.

1 Like

While you’re waiting to hear from Inventables, make sure when you try to connect through UGS, Arduino, or Xloader that you do not have Easel open in any browser. Also, if you haven’t already, try closing everything, disconnect USB for a minute, reconnect, and try again.

Personally, the chip sounds bricked, call inventables, Also make sure for future use, everything is grounded well.

Thanks for the suggestions everyone, I’ll get in touch with Inventables and let you know what the outcome is. If anything, it has made me determined to understand and pay more attention to the electronics so i’m not so lost the next time something like this happens