Having issues with my Z-axis homing

Hi,

Recently my Z-Axis limit switch broke, my fault. It got caught on my watch and bent and broke. Easy repair and not the issue. But I un-pluged my Z-axis motor on the same day and I think I plugged it back in when the X-Controller was powered. I know this is a huge NO NO but it happened in a laps of judgment.

Since I finished fixing my limit switch when I go to home my machine the Z-Axis doesn’t move. It makes a low short noise, as if it is trying to start the move and it just doesn’t. The weird part is that if I tap the limit switch quickly it will start moving the z-axis but in the second homing feed rate. I also get a error message pop up when the homing is complete in the command box in CNCjs.

I am running the most current version of CNCjs and Grbl. Here is a link to a video:

Thanks

Can’t see the video. Try uploading to YouTube.

Can you unlock the machine workout homing and jog the Z axis?
Please share your grbl settings.

Hi Neil,

Thanks for reading my post. I finally got to working on the machine again today after being called out to work for the last couple days.

I was busy getting all my Grbl settings and noticed that my $132 ?? (Z-Axis max movement) parameter was set to 0… Which is odd as I did not change that value in Grbl whilst sorting my homing switches.

The machine is all back to its normal self.

Thanks

1 Like

Good find.
Axes homing/probing will limit themselves to 150% of whatever softlimit travel that is activated ($130-132)
150% of 0 is…0 :slight_smile: