Inventables Community Forum

Help loosing connection!

So, I have spent the last week or so upgrading my spindle to a 2.2kw 220v spindle with VFD. I finally got it all up and running and it was actually working for a short time.

Today, I started a carve and it got partway through and it lost connection to the computer. I tried restarting the computer and going again… same result (different stopping place).

After trying a new USB cord, plugging the x-controller into a different power outlet and a few other things, it seems like the problem is with the spindle.

By the end of the day, whenever I started the spindle, it would immediately loose connection.

Here is the setup.

The VFD is hardwired to a 220v line directly to the panel.
The wire from the VFD to the spindle is a 16ga shielded wire that runs above the machine and nowhere near the x-controller.
There are no wires connecting the VFD to the X-Controller
When I unplug the spindle from the VFD, and hit the Run button, the connection stays on… it is only when the spindle actually powers up that it looses connection.
The X-Controller is on a separate circuit from the VFD.

What could it possibly be?

It’s noise …

Try connecting the shielding of each stepper cable together and to a GND connection on the X-Controller. If EMI is being picked up by the stepper motor cables and introduced back into the X-Controller, this should help.

{:0)

Brandon Parker

In case anyone had similar issues I’ll post what I did to fix this.

I’ll start by saying that I don’t actually know the root of the problem, other than it must have been EMI created by the spindle.

My machine is not really an X-Carve anymore. I upgraded the rails, gantry and z axis with cnc4newbie.com so it is a solid aluminum body with linear bearings and lead screws (vs rubber wheels and belts)… this means the the entire machine connects the ground on the spindle.

With ANY cables connected to the back of the X-Controller, stepper motors or limit switches, the machine would loose connection. In other words, even if just the Limit switch plug was in, the machine would loose connection the second the spindle starts. And before you suggest it… I changed the USB cable several times… that was not the issue.

I was doing some testing on the spindle and removed it from the mount… the machine ran with no problems. The minute I put it in the mount, I would loose connection.

I tried grounding the rails in different places, tried grounding the shielding wire to the X-controller, grounding the shielding wire to the chassis, directly to the shop ground… every combo.

I replaced all the wiring with braided shielding wire and grounded it.

Finally, the only solution I came up with is that I made a new mount for the motor out of a phenolic material (hard but non-conductive)… it runs perfectly. (Of course I had to put my old router on to make the mount for the new motor :stuck_out_tongue_winking_eye:)