Help needed: Easel on Mac can't see my CNC

CNC newbie here. Just got a Sainsmart 3018 ProVer from my wife for Christmas and am having issues connecting to it on my mac.

I am able to get both Easel and Candle to see the CNC on my Windows laptop so I know it’s working and the USB cable is good.

On my mac, Easel can’t see the CNC. I can’t use Candle as the Candle CNC “CH34x” driver can’t be installed due to the known macOS compatibility/security issues.

Here’s my setup:

  • Intel based Macbook pro 16 inch 2019 (4 USB C ports
  • Sainsmart 3018 ProVer CNC, GRBL controller 2.1 (what the controller module shows on the screen)
  • Mac OS 12.6 (Monterey)
  • Using Chrome browser version 108.0.5359.124
  • Downloaded and installed the “Easel driver” Mac package (installed with no issues/warnings).
  • Easel works fine other than not connecting. Also tried it using Safari with the same no-comm issue.
  • I have tried plugging the cable into each of the 4 USB ports with no connection
  • I have “Parallels” and can run Windows 10 on my Mac, but still have the same problem where Easel and Candle can’t see the CNC even with the proper Windows drivers installed.
  • On my Windows laptop, it works fine depending on which USB port I plug it into.
  • In the Mac “system report”, I don’t see anything listed in the USB section when the CNC is plugged into any of the 4 USB ports

I suspect it’s something weird the Mac USB PORTS.

I do have a Wacom tablet on the mac (not plugged in but I did install the Wacom driver) but there is no “conflicting USB driver” on the mac I cab find as noted on the Easel help pages.

Appreciate any advice on how to get Easel to see the 3018ProVer on my Mac

Thanks!

– Kevin

Did you try to install the driver for the CH340?
It doesn’t matter what sender you use if your computer can’t communicate with the CNC controller.

1 Like

Thanks, Neil. On the Mac, I have downloaded and tried two driver packages: “CH34x_Install_V1.4.pkg” and “EaselDriver.pkg”. Neither one lets Easel talk to the CNC.

It does work fine on my Windows laptop, so it’s something with the Mac-specific USB driver I assume

I thought MacOS was supposed to have these drivers pre-installed. Did you install the drivers before you tried to connect?
I’d start by removing anything you installed. Restart the computer, and try to connect to the serial port (using something other than Easel).

I installed them only after both Easel and Candle would not talk to the CNC out of the box. I will try and remove them and start over.

I have some other older USB hardware (temp sensors & digital data collectors) that have similar issues on the Mac, but work fine on any new Windows laptop. I suspect there are some issues with the Mac USB ports working well with really old drivers that (I think) were originally old RS-232 serial drivers that were modified to work with modern USB ports.

Thanks again for the ideas.

– Kevin

Here’s the official driver from the manufacturer of the CH340s

Thanks Neil. This seems to be the same driver as on the Sainsmart site. I reinstalled it, seemed to install OK but the CNC still does not show up in the USB tree as it showed in the instruction PDF. Easel can’t see it either on any of the 4 USB ports.

I also uninstalled my Wacom tablet software on the odd chance it was mucking things up. It made no difference.

1 Like

Restarted since reinstall?
I’ve seen some Mac threads that seem to say that’s the cure.

1 Like

Yes, have restarted several times,

1 Like

I don’t have much else to add as I don’t have a Mac. The last thing is reiterate is to try connect through your terminal or something like the Arduino IDE. After that works, then try easel.

1 Like

Thanks for all the suggestions. For now, I can use my Windows laptop until I sort out the connectivity issue on the Mac.

1 Like

Kevin, I discovered the hard way that the presence of certain drivers (e.g. for a Wacom tablet) will prevent a Mac from communicating with the CNC applications. I think you have to remove whichever driver is at fault, not just turn it off.

1 Like

Thanks. I uninstalled he Wacom app but it did not fix the comm issue. I will check the Wacom site on how to remove the drivers and app.

1 Like