Help with Fusion 360 tool paths

Hey fellow x carvers,

I am having a small issue with tool paths generated in fusion 360. I generated a path using the easel post processor. but when I load it in easel work piece zero is offset by .932 in in the x and y. Using the same setup and post processing with the gbrl cps this offset is gone. I used the visualizer in UGS to confirm. I am not savvy enough in gcode to interpret what is causing it. Using the easel post processor and easel to send the code i did a test cut in foam and was able to actually measure the offset. I am heading to the garage now to run a test cut using USG and the gbrl post processor after i set my G28.1 which i just learned about from @PatrickRainsberry great post on the subject. Also i set my setup zero in fusion using a modeled solid for my stock and sticking to origin on the bottom left corner. Here is a few print screens to show better.

Post with easel cps in easel

Post with gbrl cps in UGS

Post with easel cps in UGS

Thanks for any thoughts!

Assuming you mean the 0.932 offset is the starting point to the path, what is stock origin, stock size, and stock offset set to within Fusion? That determines the starting point of the tool.



I made a solid with the same dimensions as my stock and placed the origin in setup on the top of the lower left hand corner as this is where i planed to zero my tool after homing. I selected body in setup for stock. The 0.932 is the distance is what appears to me to be an offset from what i thought was work piece zero to what the easel post processed files work piece zero. Not sure if that helped or muddied the waters. The screenshots above are the same setup and tool path only difference was the post processor.


Hmmm, I don’t use the easel or grbl post processor, I use the shapeoko2. That said, I can’t imagine the post processor would change the origin. Can you post some screen shots of fusion? Maybe there is something non-obvious there.


Yep my guess is that there is an origin set wrong somehow. I’ll need to take a look at the easel post and see what options are set.

Tom, Patrick,

I figured it out…Patrick you sparked the idea when you said post options.

See where it says clamp offset 1? I put that to zero and viola…problem solved. I didn’t even realize these were user configurable. I was so focused on origin in set up i missed the obvious. Thanks for looking at with me gents!

Best Regards

Great work. I guess my post process doesn’t have any configurable options. I might consider switching…or maybe not :wink:

That clamp offset is actually really useful for Carvey. Because on Carvey the zero is always machine zero so it is fixed. That offset lets you actually set the part out say 1"x1" from the clamp zero. On X-Carve it would just throw you off by that amount. SO for X-Carve definitely set to 0.

Hi folks,
I’m having this same offset issue with running Fusion 360 g-code through importing to Easel, but I can’t figure out where this screenshot is coming from to find the clamp offset value and zero it. Would you please give me more breadcrumbs on where/how you’re editing that setting?
Many thanks,

Hey Brian,

That screen pops up when you select post process in fusion 360. There you get the option to select which post processor to use, nc file name and where it’s written etc. This is also where you will find clamp offset. Let me know if it solves it.
Best of luck

Thanks Joe,
That makes perfect sense but I guess working on a Mac I didn’t recognize the dialog box as it appears in Windows!
So I found it, but it doesn’t seem to be the source of my offset since clamp offset’s already set to 0 (see screenshots pls). Any thoughts on what I’m overlooking?
Many thanks,

Brian if you want I think you can share your fusion project then I can open it post it and see if I get the same problem. Let me know be glad to do it.

Hey Guys. I am Also Having a hell of a time with fusion. using ugs with the easl cps I got 9 to 13 min in and the whole design started cutting 3 inches left! Checked belts nuts potentiometers and it happened multiple times. I am going to try to use a different post for ugs than easel. idk if this was the problem but I have not been able to get 1 successful carving through fusion 360 and ugs in almost a year. I am now considering selling my machine. sad. I can make files even g code files but I just cant get a single correct carving in 3d. Easel has no after edit features once you import g code. and many times the design is off the table comepletely! I will try the clamo offset. hopefully it helps.

Hey Paul sorry to hear your having such a hard time. I use fusion with the easel post then easel to send the Gcode and it works great. I would be glad to help you any way I can but will need some more info. First if you get a sudden shit I have a hard time believing that’s in the code. U can test that with a g code simulator there are free ones. I recommend you simulate in fusion. If that’s good then post and sim in a Gcode simulator. If that’s good then most likely the problem is in the machine. If the code checks out then review all the grbl parameters. When you adjusted your pots did you use a voltmeter? Just to have a number to compare to. Let me know how the tests go.
Best of luck

I had a similar issue… I would lose steps on the y axis… I went back and increased the power output from the motion controller for the y axis and I stopped losing steps…