Help with y axis direction change

I was in the middle of a project and I had compleated the roughing pass so I switched to my detail bit, homed it then when I went to carve the gantry went the wrong way. I didnt change any settings i just tried to cut again with a smaller bit. Is this a setting in easel or did something just break. It only happens during the detail pass and not the roughing pass, maybe its an issue with the two stage cut feature?

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

How did you do that, you don’t have homing enabled?

I had that happen on my first try at a 2 pass carve but I didn’t reset the home position (work cords not machine cords) in Easel before starting the second pass. Did you unplug the electronics in between passes? If so, when you plugged it back in, it reset the machine zero coordinates but the work coordinates would still persist as relative to the machine coordinates so if you didn’t click the button in Easel to set the home position, it could cause the wrong movements.

I had to refined the home position by hand after I changed bits because i moved the router. No I didnt unplug anything and I tried to reset the home position with no luck. I then shut everything down and restarted the project with the same result. I have been using the 2 stage cutting a bunch since I got it so its not like this is my first time.

then I shouldnt be having any issues my spindle was in the same place when I started the roughing pass and the detail pass. When I say by hand i mean that I jogged it using the arrow keys I dont have homing switches.

I have been using the 2 stage cut for a while now so I know how to use it pretty well, I have to move my router to get it clear of my dust boot if I want to change bits. In this case I raised it up and was able to change it so I only moved in the z axis. That being said I have jogged it in other directions on other projects and the only thing that happens is Im slightly off on the next pass because it wasnt homed perfectly, it did not invert my y axis. That doesnt matter anyway because I only moved the z axis for this project.

Why is it still like this even when I have started the project over, it makes no sense since it would be using my new home position when I start a fresh project.

Try exporting the Gcode for the detailed pass then start a new project and import the Gcode to see how it loads the Gcode file. I believe it’ll show the paths which should show if they are in the right direction per the design zero point.

I will post a video when I get home from work. I wanted to come up with a way to show what I’m doing in easel and what the machine is doing at the same time.

1 Like

I have a video of it without a bit to show what it does but I got sick of waiting so i went into another project I know works deleted what was in there and just re imported my svg and that seems to work fine. i would like to know why it did this but since i was able to complete the project this way its not as big a deal.
ill post the video anyway.

1 Like