Hole pattern becomes off after 5 drills

I am having quite a strange issue than I have yet to encountered in the 3 years I’ve owned my x-carve.

Just some background, I recently upgraded to the x-controller and stronger x-axis, I reinforced the y-axis myself, and replaced the x axis with a stronger dual rod axis. I had everything working great after the upgrades, with pretty good accuracy (way better than before).

Then I did a firmware upgrade. Next time I tried is when the problems started.

A few weeks later now, I’m trying to cut an aluminum plate. Using a double flute 1/8th inch bit made for aluminum specifically. The issue is the holes become off after the 5 hole is drill. The whole pattern becomes off afterwards. The weirdest part is the bit does return to the correct starting location when it’s done or canceled.

First thought is the belt is slipping. But the belt has good tension. Checked the pulleys to make sure the grub screws are not slipping, they are good also. This would make sense also if the bit returned to the wrong location afterwards (which I’ve experienced a fair bit in the past couple of years), but it returns to the correct location, so it doesn’t seem physical to me.

So I decided to redo the firmware on the machine. I re-calibrated all axises with calibers. Still, same problem.

Thinking this could be because the file is very old, that maybe, it wasn’t converted automatically to the correct format in all of the iterations of firmware of the machine and easel. So I created a new file, and redid the sketch again. Still, same problem.

I’m completely out of ideas now. Seems to me like a software glitch, but I have no way of confirming this.

Any ideas of how to fix this or what the problem might be?


The same file was working before firmware update? What firmware did you upgrade to? Have you updated your grbl settings since you upgraded?
Are you sure the first 5 are correctly located?

Yes, the file was working correctly before.

Firmware is 1.1f.
After updating, I touched noting and ran it to find the issue.

Afterwards, I did the machine setup over again, which basically reset the settings.

Then, I adjusted the z-axis to the correct value for this rod. I left the x and y at 40, since it was very close to perfect. I made sure not to touch any other values.

And yes, I’m 100% sure everything is correct. I even used the align feature in easel to align the wholes in straight lines with each other, just in case.

I meant are the first 5 holes actually drilled in the correct locations? Just trying to narrow down the point when things go wrong.

As far as I can tell, yes. It starts from the bottom left corner, goes up to the next hole on the far left side, then the next hole above that, then back to the right and up again, then to the right, and now it’s time to turn around again, and the next hole is where the problem starts.

If you were to run the code again, does it do the exact same thing?
It seems mechanical. Is everything square when you start?Firmware wouldn’t make a difference if everything is calibrated. Can you share the project or gcode?

What do you mean?

It does the same thing over and over again. Already waste around $60 in aluminum sheets because of all of the bad cuts. Some times, it will be slightly more off than others.

https://www.inventables.com/projects/vesc-heatsink-quad-has-issues

I also split this into 4 separate files (1 for each horizontal line of rows) and when cut like this, theirs no alignment issues. Then I tried to cut the plate out and that also messed up on the final turn.

Save your material till its cutting right and use mdf or ply to test it. Is the mistake hole exactly the same after each carve?

It always starts the mistake in the same place, but it’s not always off by the same amount. Seems to vary by as much as 2mm.

The hole before the mistake, exactly the same as all the rest?
Do a cut in something not alu.
Recreate the project and do each hole individually(no copy paste). Does it persist?
Try each row in zones?

That wouldn’t be the firmware or your code.
If you’re sure you checked everything mechanically, it’s possible you have a issue with the wiring to a stepper.

OP state that the bit return to zero, if true that indicate no loss of steps.

If that is indeed true then it is in the code somewhere since it is consistent.

Is the design made in Easel or is it gcode-import?

Why don’t you start from the beginning when troubleshooting?
Check your hardware!
Check your electronics!
Check your settings!

If that doesn’t fix it it may be a software issue and that’s something you have to work on.

What have you done so far? And can you plz post your settings.
Everyone says they checked but always miss something small like pot adjustments or belt tension.

I’d like to see the gcode.

I try not to assume anything. That’s why I asked if he starts the code again whether the holes were in the same place or not.

The OP also stated that the results vary each time…not code.
He also shared his Easel project. The toolpaths look fine.
He also stated that other cuts result in an error in the same place.
To me, this adds up to mechanical or electrical, not toolpath or design. Without more information, it’s tough to say for sure.