Homing is very very slow

I recently did some improvements to my CNC and found my relay was not working so I went to Easel to reset my machine, and somehow changed the GBRLsettings as my jogging and homing are very very slow, I can’t get back into Easel machine setup again to try and fix it, I have also just noticed that if I try to jog 20 inches it only moves about 3 inches it is trying to get the speed up but the distance is too short 3 inches

Hi Patrick,
What Model CNC is this, and If it’s an X-Carve what year model is it (Pre or Post Nov 2021)?

When the X-Carve options are selected in Easel’s Machine Setup those machines specfic Calibration settings are pushed to the machine and it is likely that the incorrect Year model OR the incorrect Upgrades were selected and this will effect the calibration of movement as well as the speed of movement.

If you think this might be the issue, the simplest fix is to re-do the machine setup and select the correct version X-Carve AND if it is the earlier model make sure to select the appropriate upgrades (If it has any) on the 2nd screen as well.

Hopefully that helps!

1 Like

Hi Seth
Thank you for the quick reply, it is an X-Carve and pre 2021, I am pretty sure I clicked the correct machine but maybe not, I think you are correct and I did try and go to the machine setup page again but it tells me that the machine is already setup and that I need to upgrade to setup another machine

1 Like

Ok, youll want to go to machine>edit machine then at yhe bottom is the option to delete the existing machine setup. Then it will let you redo the setup without rhe pay wall warning.

Thank’s Seth, all working great now, except my relay switch not turning on the spindle, I am working on that now, thanks for your help

1 Like

Possibly the machine settings in easel?
Go to machine>edit machine and ensure its set to “hardware” and "other (or 24c spindle works too) "