Inventables Community Forum

Homing Issues Z-Axis

I’ve checked the other posts here and I didn’t see my issue so I’m hoping someone can assist. Much like others, I’ve upgraded to the 9mm belts, stiffeners, etc. but when I tried to run the setup for a new machine and test the homing the z axis smashed into the limit switch and tried to keep going. I’ve checked the machine inspector and the z limit switch is working, it lights up when contacted. I’ve checked and rechecked my wiring and it’s done to spec.

I haven’t even gotten past this to check the other switches, any ideas?

Are you sure it is hitting it in the right spot to trip it.?

Yes, I’m as sure as I suppose one can be! :slight_smile:

If it is working by hand then i would say the z axes is not hitting it correctly to trip it .Run it up to the switch real slow and see how it is hitting it.

1 Like

Just a couple random thoughts. I’d look at settings $20-$27. What is $20 set at? Make sure that your settings are for homing switches enabled. There is also a setting that you could check. $27 Homing pull off. The distance it backs up after hitting the switch to make sure the switch opens back up enough.

GRBL_Settings_Pocket_Guide_Rev_B.pdf (diymachining.com)

I agree with Wayne and suspect the limit screw is stopping it before the switch is activated.

1 Like

I’m having the same issue with my new x carve

Is homing enabled $22-1 ?

Actually just figured it out. The homing switch wasn’t making a good enough contact. I had to loosen mounting screws to homing switch and push down the homing switch just enough to get the paddle to sit a tiny bit lower. I was able to complete the homing process with no issues. thanks for the help.

3 Likes

Thanks for the replies!

$20 is set to 0
$21 is 0 as well
$27 is 1.000

I just ran things again after changing the settings to 1 then back again and somehow homing is working. Can’t explain it.

1 Like

So is homing, $20, is now Zero again?

Yes, $20 is 0 again