*homing sequence

limit switch for the x and z-axis does not work but it is well soldered.


Please provide a little more information. What method are you using to test the switches and how are they failing?

have you enabled the limit functionality in the grbl settings?
By default it is disabled.


how do i enable it?

when i do the homing sequence the x-axis does not move only the y-axis and it stops when i press its
limit switch. i redo the molex connectors and the x-axis motor does not move and limit switch still
does not work. how do i enable it on the grbl settings?


Read these threads and see if you can use the Arduino IDE serial monitor to get the grbl parameters and post them here.

1 Like

Can you go into Easel -> Machine Tab -> Advanced -> Machine inspector, then copy paste all the $ settings here?

where do i find -> Machine Tab -> Advanced -> Machine inspector on easel?
i have arduino sketch_may11a and i do not see -> Machine Tab -> Advanced -> Machine inspector there.

i dont even know how to use it why would i mess with it?

1 Like


where do i find this?

Find what?

http://easel.inventables.com ?

Those settings are pulled from whatever machine is connected. Plug the USB in and when the carve button turns green, open up the inspector again.

i found out this is not really necessary.