Homing Switch Turns off Y-1 Stepper Motor but Y-2 keeps running (Resolved)

Setting up new 1000mm X-Carve. Checking homing switches and all work except Y-2 Stepper does not shut off even though Y-1 does. HELP!!!

You have a wiring problem. Make sure that you have the X motor wired to the X driver on the X controller.


Thanks. I don’t know how I could have missed it or why I did it, but I found the x limit wires in the y limit terminals and the y limit wires in the x limit terminal. Should probably work fine now. Had me going for awhile because during the initial test, all axis’s worked fine (manual control in each direction). Had also checked the limit switches to make sure they were all working properly. Never occurred to me that I may have reversed the x and y limit wires.Duh!

1 Like

Well…It seems the problem persists. After switching the x-axis & y-axis limit wires, and checking all other external wires & connections, the y-axis limit (both stepper motors) now shut off when the limit switch is closed as it should. BUT…now the x-axis stepper motor won’t shut off when the x-axis limit switch is closed.

SO…I perused the forum and looked at what others had to say about the problem. I opened the controller, and double checked all of the internal wiring (ribbon connectors and such). Checked control buttons - none of them hanging up. Put everything back together and tried the test sequence again and the x-axis motor wouldn’t stop when the x-limit switch was closed.

When I had the x and y limit wires backwards, that is to say the y-limit wires were in the x-limit socket, the y-2 motor kept going, but I also suspect the y-1 motor was probably still running too, now that I think of it - the rail being stopped (physically) by the limit switch stop.

I’m now thinking there may be a circuit board problem, but for now, I think I’ll wait till Monday and talk with Inventables to see what they think. Everything else seems to work fine otherwise. Thanks again for the suggestions.


I think we can get you going or at least isolate the problem if you want to continue trying to get your machine working.

Check to make sure that the cables within the X-controller are fully seated in their sockets. The strain relief clips will close prior to fully seated the cable.

There is a new feature in Easel that allows you to test the switches, to see if they are being read properly by the computer. I don’t use Easel so I can’t point you to the right screen for that, but you can use a terminal type program to talk directly to grbl through a serial port.

These two items will get you directly to the homing switch inputs. Link LInk

Thanks again, LarryM.

I disassembled the x-controller yesterday and went through all of the connectors, checking all were seated properly. Also checked continuity through switches, connectors, wires, etc. and didn’t find anything wrong.

I’m going to play with it again this afternoon and go through everything one more time just in case I missed something. Who knows? I might get lucky.

I can still use the machine with the homing switches disabled (they were added as an option), but since I paid to add the optional upgrade, I may as well make it work.


This is what I found:

When the x-axis carriage moved to the left, towards the x-axis limit switch, the carriage itself was hiting the spacer for the limit switch stop. Although the switch was physically functional and looked as though it was closing, the spacer held the carriage back just far enough to prevent the switch from closing all the way and stopping the x-axis stepper motor.


I held the switch lever against the switch at the hinge to prevent damage, and gently pried out the contact end of the lever with a pair of needle nose pliers. This allowed the switch to close earlier and shut off the x-axis stepper motor before the carriage could keep trying to continue on.

Actually Phil,

The switch was not crushed at all. It had the exact same shape and appearance as all the others. The spacer just stuck out a bit too much, and I probably could have loosened the screw and moved the spacer over because they have a bit of slop in them, but it was faster and easier to simply bend the switch lever out just slightly. No need to replace - works just fine now.

1 Like