Homing Z-Limit Failing (X-Carve)

Hello All,

My Z Home has failed. When I investigate and open up the following articles, it tells me to text the homing switches. All the switches go green in the test, but the Z. I have gone as far as disconnected all the switches, and reconnected, to no avail. I even tested a different axis on the switch to see if the switch failed. The switch engaged the test axis. https://inventables.zendesk.com/hc/en-us/articles/360012726194-Homing-cycle-fails-X-Carve-

I am at a loss, I dont know what to do. I am in crunch time for Winter Market, looks like I am SOL.

I will upload a Video to show what I am going through.


X and Y are Homed, Z is not. Hence the 0.845.

check your “Z” manually with your finger if it works? possibly just need to bend that little arm out with a needle nose pliers.

No dice, I hit it and nothing happens. When I switch the wiring form another switch, and tap it, it works. So, it’s not the switch. Its a wire, or something else… It was mid carve, then I went to switch bit, and boom, this happened.

how about a couple of pictures of what you have including wiring at back of controller too.

Wiring was not adjusted since the last carve, I have unplugged and re-plugged in to make sure strong contact. Here is the back Panel:

Heres what I have done so far:

  • Disconnected Z-Axis Homing Switch from Switch and Main Controller
  • Ensured good contact on Both Ends.
  • Tested X / Y AXIS Wires on the Z Switch to ensure it’s not a failed switch (See Video)
  • Inspected “Z-Limit” Wire from Controller to Switch
  • Removed Machine, Re-added, Re-uploaded Firmware
  • Power Cycled Machine

I am at a loss for what is next. I have noticed today that the machine just stops carving mid carve. I researched and saw that the vacuum can cause this. I have a Powered USB HUB, New Shielded Cable, Laptop is not “going to sleep”, Wifi is Stable.

Could the machine simply be failing?

The plot thickens. I just did the following, and still is not working.

  • Removed the Wire from a working Axis (X) from controller AND switch.

  • Moved it into the Z Sensor and Controller spot and it still didnt work.

  • Which tells me, its not the wiring, as the wiring works.

  • It’s not the sensor, as I tested above.

  • It has to be something else within the software, or a hardware failure. X, Y, Z Axis work find with controls, just doesn’t “Stop” with the switch when going up for Z.

Hey Luke, is this the newer version Z-axis, with the linear rails and the motor mounted to the very top?
IF it is have you tried this?

Did all of this! I even tested with the other Axis, the switch is working. It HAS to be a problem inside the main controller, on the other board,

1 Like

Including Circuit Board Photos.

1 Like

not sure if this is off from having to take it apart for the photos, BUT this cable is what connects the green plug (for X,Y,Z limit switch) up to the controller board on the top… making sure its plugged in fully and snapped in place is just about all that can be done other than replacing things like the main board, or the cable itself…

I just got the X carve (December 2022) and I am having this exact same issue! Did you ever find a solution? I contacted Inventables today and hope to get a call back soon.

Z and Y Homing switches work fine and show green on the Machine Inspector. X Homing switch isn’t registering on the machine inspector and isn’t stopping the machine during homing.
I have tested and passed:

  • x limit wire conductivity (no breaks in wire)
  • x homing microswitch and tried other switches in the extras bag
  • homing actuator pins on the rails (it engages properly in operation)
  • ensured that all wires are connected properly (many times)
  • checked that that no labels are swapped on the cables (saw that happened on a thread while researching this issue)
  • disassembled the x controller and reconnected all clips
  • deleted and reinstalled the easel driver

So I think I’ve traced it back to either the green connector to the back of the x controller or the electronic board it connects to. The latter would not be ideal! Hopefully it isn’t a bug with the latest batch of x carves.

1 Like

I took it all apart and reconnected. It was a pain, but it worked As SethCNC said, that ribbon cable could have been the problem.

1 Like

Great! Glad you got it solved. Mine was much the same solution.

I had taken apart the controller and reseated each of the gray ribbon cables and it didn’t fix it. But an Inventables tech suggested I swap them and see what happens and it worked! Not sure why, but its fixed now.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.